Click here to Skip to main content
12,300,841 members (67,691 online)
Rate this:
 
Please Sign up or sign in to vote.
See more: ASP.NET
i hv uploaded my website to livetrainings.in

when im requesting the site it is trhowing the error like

Server Error in '/' Application.
whatt does it mean.my appln running successfully in local system.

and when i add only single page to the site it is running fine.

when i add total pages to the site im getting above error

please guide me to resolve this problem
Posted 30-Jan-13 23:11pm
Comments
Ankur\m/ 31-Jan-13 5:16am
   
Can you set the customError mode to 'off' in your web config to see the error description?
syedkhaleel 31-Jan-13 5:33am
   
i set it to off now
syedkhaleel 31-Jan-13 5:37am
   
how to set connectionstring for hosting site..i have db backup file in my local sys.i want to upload it.how can i use it .i have to restore .or uplaod .mdf file
Ankur\m/ 31-Jan-13 5:49am
   
Did the hosting provider not give you a database access? You will need to check out with them how you restore your db backup there.
For the connection string, edit your web config or else you can do it using IIS as well.
Ankur\m/ 31-Jan-13 5:49am
   
And yes, use the reply link to reply to a comment. I do not get notified otherwise.
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

Try to check the path of your website, maybe mispell with slashes "/"
  Permalink  
Comments
syedkhaleel 31-Jan-13 5:35am
   
i have to change the connectionsttring..how to set the connstring according to the remote db serrver..credentials
can gv a example of it.
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 3

First :
It is a big mistake(security threat) to leave custom errors enabled in web.config file before deploying your application to production server. (Unless you like you server to be hacked formatted or whatever)

Second:
con = new SqlConnection("Data Source=localhost;database=scmtraingdb;user id=sa;password=123");

This looks like the code on the development machine you need to change the connection string according to the server on which your application is hosted. Ask the web space provider or someone with experience in asp.net to configure it. You don't need to change it in code.you may store it in web config file itself.

You need to deploy the database on the web Server too;


Hope it helps!!
Best of luck!!
  Permalink  
Comments
syedkhaleel 31-Jan-13 5:39am
   
thanq..
Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 4

I followed the URL livetrainings.in.there is a problem with your database connectivity in your usercontrol. Please check the database connectivity.

Thanks
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Mobile
Web02 | 2.8.160525.2 | Last Updated 31 Jan 2013
Copyright © CodeProject, 1999-2016
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100