Click here to Skip to main content
11,790,946 members (51,326 online)
Rate this: bad
Please Sign up or sign in to vote.
See more: C#
Im trying to consume a WCF service in Sharepoint 2010 through Webparts. I followed this link for doing it.

But I'm not able to discover the Service.svc while adding service reference in the client. It shows error regarding metadata.

Can anyone help Please??
This is my web.config file
        <behavior name="WcfService.RevertServiceServiceBehavior">
          <servicemetadata httpgetenabled="true" />
          <servicedebug includeexceptiondetailinfaults="false" />
      <service behaviorconfiguration="WcfService.RevertServiceServiceBehavior">
Posted 6-Feb-13 22:47pm
Edited 7-Feb-13 17:54pm

1 solution

Rate this: bad
Please Sign up or sign in to vote.

Solution 1

Sureshbalajin at 7-Feb-13 6:13am
Thanks Rohit.
But, When I followed it I got stuck up at step 23. Im not able to discover the MyService.svc. Say my site URL is http://VM11:2505/sites/SPDemoSite , my project name is WCFSPProject1 ,namespace WcfServiceLibrary1 and my serice file name is MyService.svc. Then what could be the possible location where the .svc file can be discovered. What is that _vti_bin ? Does it apply for all machines?? Pls can u Help ??

Krunal Rohit at 7-Feb-13 7:11am
your web.config is correct ??
Sureshbalajin at 7-Feb-13 10:30am
Ya i hope so...

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 ppolymorphe 385
1 OriginalGriff 385
2 Richard MacCutchan 118
3 Jochen Arndt 85
4 Maciej Los 70
0 OriginalGriff 1,329
1 Maciej Los 835
2 ppolymorphe 780
3 KrunalRohit 686
4 CPallini 661

Advertise | Privacy | Mobile
Web03 | 2.8.1509028.1 | Last Updated 7 Feb 2013
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100