Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C# WCF VB.NET
hi everyone
i wrote a wcf service(SVC)
when i run my service in my computer it works without any problems
bu when i upload my service in my host it has Not Found Error
Where is my problem
my service link
 
my Service web.config :
<?xml version="1.0"?>
<configuration>
  <system.web>
    <compilation debug="true" strict="false" explicit="true" targetFramework="4.0" />
  </system.web>
  <system.serviceModel>
    <behaviors>
      <serviceBehaviors>
        <behavior>
          <!-- To avoid disclosing metadata information, set the value below to false and remove the metadata endpoint above before deployment -->
          <serviceMetadata httpGetEnabled="true" />
          <!-- To receive exception details in faults for debugging purposes, set the value below to true.  Set to false before deployment to avoid disclosing exception information -->
          <serviceDebug includeExceptionDetailInFaults="false" />
        </behavior>
      </serviceBehaviors>
    </behaviors>
    <services>
      <service name="Chat_Server.Service_Chat">
        <endpoint binding="wsDualHttpBinding" bindingConfiguration="DuplexBinding" contract="Chat_Server.IService_Chat" />
      </service>
    </services>
    <bindings>
      <wsDualHttpBinding>
        <binding name="DuplexBinding">
        </binding>
      </wsDualHttpBinding>
    </bindings>
    <serviceHostingEnvironment multipleSiteBindingsEnabled="true" aspNetCompatibilityEnabled="true" />
  </system.serviceModel>
  <system.webServer>
    <modules runAllManagedModulesForAllRequests="true" />
  </system.webServer>
</configuration>
 
thank you
Posted 11-Feb-13 0:23am

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Hi,
 
Take a look at the error message, it's a known issue, try this:
 
The page you are requesting cannot be served because of the extension configuration[^]
 
Hope it helps
  Permalink  
Comments
_Zorro_ at 11-Feb-13 9:47am
   
It seems to me that your IIS is not properly configured to host svc extensions. Just read the error: "The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map."
 
-> "If the page is a script, add a handler"
 
Take a look at your Handler Mappings (in IIS) and look at .svc extensions. If you find some, check if they're enabled. Otherwise, that would mean that wcf if not properly installed on your web server and needs to be re activated.
Sina asefi at 11-Feb-13 10:43am
   
thank you it's right

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 295
1 DamithSL 265
2 CPallini 235
3 Maciej Los 190
4 Sergey Alexandrovich Kryukov 174
0 OriginalGriff 5,415
1 DamithSL 4,422
2 Maciej Los 3,820
3 Kornfeld Eliyahu Peter 3,470
4 Sergey Alexandrovich Kryukov 2,911


Advertise | Privacy | Mobile
Web01 | 2.8.141216.1 | Last Updated 11 Feb 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100