Click here to Skip to main content
11,634,486 members (72,801 online)
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C# Oracle DevExpress MVC4
Hi there,

I have published a MVC website interfacing an Oracle Database. All server settings have been configured as necessary.

Problem: When I run the application locally it works fine, but from the server I get the following error: "Could not load file or assembly 'XXX.YYY' or one of its dependencies. The system cannot find the file specified."

This is my first mvc application and the error is not really clear as it is generalized as everything is on the server.

If you have any suspicions on what it could be then please do assist.

Regards
Posted 20-Feb-13 19:59pm
Comments
Jameel Moideen at 21-Feb-13 3:31am
   
please verify the version of assembly

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Make sure your application's all private assemblies which you use to your application are properly deployed it to iis. How you can identify? Your local application which you say that it is working its bin directory and your deployed application to iis bin directory files are same with same version.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 8,758
1 Sergey Alexandrovich Kryukov 8,264
2 Mika Wendelius 6,755
3 F-ES Sitecore 2,344
4 Suvendu Shekhar Giri 2,095


Advertise | Privacy | Mobile
Web02 | 2.8.150728.1 | Last Updated 22 Feb 2013
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100