Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: QT-Creator
I am new to Mac os and i just installed qt creator and created new Qt console application to test whether the compiler works or not. When i try to build it i am getting error that says token is not valid binary operator in a preprocessor subexpression #if __has_extension(is_enum) .... on Qt5.0.1/5.0.1/clang_64/include/QtCore/qisenum.h
And i have tried to google it but i couldn't get satisfactory solution for it.
 
With regards,
Posted 27-Feb-13 2:40am
Edited 27-Feb-13 5:15am
495.7K
v2
Comments
Richard MacCutchan at 28-Feb-13 11:26am
   
Either or both of the macro expressions __has_extension or is_enum, do not exist in your version of the compiler.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 279
1 Maciej Los 168
2 George Jonsson 154
3 Sarvesh Kumar Gupta 130
4 Dave Kreskowiak 130


Advertise | Privacy | Mobile
Web01 | 2.8.140709.1 | Last Updated 28 Feb 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid