Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
I have just created a sample webservice in my visualstudio.net in visual basic project.
It is having a web method Helloworld.
 
when I am pressing F5, an error is comming( i unchecked "show user friendly error" in IE advanced settings.
Server Application Error
The server has encountered an error while loading an application during the processing of your request. Please refer to the event log for more detail information. Please contact the server administrator for assistance.
 
this is the url coming in IE <"http://localhost/WebService1/Service1.asmx">
 
Mine is Windows XP professional ,version 2002, SP3 , IIS V5.1
 
I am not getting how to solve this one.Kinldy help on this.
 
Thanks.
Posted 1-Mar-13 0:04am
Edited 3-Mar-13 20:09pm
v2
Comments
nika2008 at 1-Mar-13 5:28am
   
i am not sure try first build solution and rebuild solution??
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Have a look at the following blog: HTTP 500 – Internal server error[^]
  Permalink  
Comments
Naveen_143 at 4-Mar-13 1:01am
   
Thanks for ur response. But I dint find any solution to my problem. Any links specific to WebServices Plz...
Sandeep Mewara at 4-Mar-13 1:13am
   
- You sure you set correct .NET framework version in IIS?
- You sure that web service is working perfectly fine in your dev environment in Visual Studio?
Naveen_143 at 4-Mar-13 1:31am
   
- >.net framework version is set correctly in IIS .
- > in visual studio itself ,still developing, when I created a sample web servie and pressed F5, this error is coming. I dint deploy it any where.
Sandeep Mewara at 4-Mar-13 2:04am
   
If you see 500 internal error in VS, you should be able to debug and see it. Using VS internal webserver? What version of VS & .NET?
Sounds like you are doing something wrong at basic level and should be easy to troubleshoot for you and resolve.
Naveen_143 at 5-Mar-13 2:23am
   
Hi, Thanks ..
It was an error from setting in IIS and .net version.
I have corrected it now.
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

  Permalink  
Comments
Naveen_143 at 5-Mar-13 2:23am
   
Thanks for your reply..I have solved it.
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

The error was coming because of some services in IIS. I have changed settings in IIS and again registered the .Net version with aspnet_iisreg -i command.
 
Its working fine now..
  Permalink  
Comments
Sandeep Mewara at 5-Mar-13 2:44am
   
What exactly fixed it? What was the setting in IIS? Please share.
Naveen_143 at 5-Mar-13 7:30am
   
I checked the event logs and error was regarding W3SVC service and I checked in net about that and did some changes. I was in a hurry so I dint make a note of what are all changes I did. Sorry for that..
Naveen_143 at 5-Mar-13 7:31am
   
but at the end I found that .net version is not registerd so I used that commad to register asp.net version

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 428
1 Maciej Los 249
2 BillWoodruff 199
3 /\jmot 180
4 Suraj Sahoo | Coding Passion 150
0 OriginalGriff 8,484
1 Sergey Alexandrovich Kryukov 7,407
2 DamithSL 5,639
3 Maciej Los 5,159
4 Manas Bhardwaj 4,986


Advertise | Privacy | Mobile
Web01 | 2.8.1411023.1 | Last Updated 5 Mar 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100