Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C# .NET
Hi all,
Am building an application using C#.
I heard that Vista and later windows OSs comes with .Net framework.
 
So what is the best and latest .Net framework version to target that Vista (Without service pack) or later OS users doesn't need to install any .Net version other than the one already comes with?
 
Thanks a lot
Posted 3-Mar-13 20:03pm
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Hi!!!!
1.0 Visual Studio .NET N/A
1.1 Visual Studio .NET 2003 Windows Server 2003
2.0 Visual Studio 2005 Windows Server 2003 R2
3.0 Windows Vista, Windows Server 2008
3.5 Visual Studio 2008 Windows 7, Windows Server 2008 R2
4.0 Visual Studio 2010 N/A
4.5 Visual Studio 2012 Windows 8, Windows Server 2012
 
So if you use latest version of .net framework so you want install .netframework in old os!!!
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

Windows Vista comes with .NET 3.0 (.NET 2.0 CLR)
Windows 7 comes with .NET 3.5 (.NET 2.0 CLR)
windows 8 comes with .NET 4.5 (no .NET 2.0!!!)
 
not familiar enough with windows server versions, but they are parallel.
 
this has been a bit of a challenge for my team. and we had to build a shim to drive our code on windows 8 using .NET 4
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 495
1 Maciej Los 340
2 Richard MacCutchan 265
3 BillWoodruff 225
4 Mathew Soji 200
0 OriginalGriff 8,804
1 Sergey Alexandrovich Kryukov 7,457
2 DamithSL 5,689
3 Maciej Los 5,279
4 Manas Bhardwaj 4,986


Advertise | Privacy | Mobile
Web03 | 2.8.1411028.1 | Last Updated 15 Mar 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100