Click here to Skip to main content
11,927,156 members (52,802 online)
Rate this:
Please Sign up or sign in to vote.

I created a crystal report output using to be used for multiple people. I used the template ASP.NET crystal report to create the report. Its created and run successfully during development in MS visual studio 2008. But after host ,the default.aspx page will ask the SERVER NAME,DATABASE NAME,USER NAME & PASSWORD. Server name and user Name will come automatic and I need to give only password. When I am giving password to run the report before hosting its working but after hosting the report is not coming after press logon button.

Is there any control is missing or the database details rather than report do I need to provide anywhere. please advice.

[Edit]Shouting removed (title only)[/Edit]
Posted 2-Apr-13 4:09am
Edited 2-Apr-13 4:19am
aspnet_regiis -i 2-Apr-13 9:53am
Out of 15,434,998,787 reasons why it may be not working , I am posting two here...

1. Check if your host supports Crystal reports..
2. Enable error reporting on the application and check what error message it provides...

1 solution

Rate this: bad
Please Sign up or sign in to vote.

Solution 1

Apply the logon details at run-time dynamically.
C# Crystal Reports Dynamic Logon parameters[^]

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy | Mobile
Web03 | 2.8.151126.1 | Last Updated 20 Oct 2013
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100