Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: WCF
Hi friends
 
the following is my web config file in .net4 webservice project
 
<configuration>
 
  <system.web>
    <compilation debug="true" targetframework="4.0" />
  </system.web>
  <system.servicemodel>
    <bindings>
      <basichttpbinding>
        <binding name="Basic" />
      </basichttpbinding>
    </bindings>
    <services>
      <service behaviorconfiguration="NewBehavior" name="MyserviceLibrary1.Myservice">
        <endpoint address="http://http://localhost:20437/Service2.svc">
          binding="basicHttpBinding" bindingConfiguration="Basic" name="Basic"
          contract="MyserviceLibrary1.IMyservice" />
        
      </endpoint></service>
    </services>
    <behaviors>
      <servicebehaviors>
        <behavior name="">
          <servicemetadata httpgetenabled="true" />
          <servicedebug includeexceptiondetailinfaults="false" />
        </behavior>
        <behavior name="NewBehavior">
          <servicemetadata httpgetenabled="true" />
        </behavior>
      </servicebehaviors>
    </behaviors>
    <servicehostingenvironment multiplesitebindingsenabled="true" />
  </system.servicemodel>
 <system.webserver>
    <modules runallmanagedmodulesforallrequests="true" />
  </system.webserver>
  
</configuration>
how can solve this error.
Posted 13-Apr-13 20:53pm
Edited 13-Apr-13 20:54pm
v2
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

You should first check if you can connect and browse the service.
  Permalink  
Comments
baskaran chellasamy at 14-Apr-13 3:00am
   
i am new for wcf.so please tell me how to connect and browse the service
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

In my case I fixed it by setting aspNetCompatibilityEnabled to "false" in web.config
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

Add this to your config
 

<behaviors>
   <servicebehaviors>
      <behavior name="metadataBehavior">
         <servicemetadata httpgetenabled="true" />
      </behavior>
   </servicebehaviors>
</behaviors>
<services>
   <service name="MyService.MyService" behaviorconfiguration="metadataBehavior">
      <endpoint>
          address=""   <!-- don't put anything here - Cassini will determine address -->
          binding="basicHttpBinding" 
          contract="MyService.IMyService"/>
      <endpoint>
          address="mex" 
          binding="mexHttpBinding" 
          contract="IMetadataExchange"/>
   </endpoint></endpoint></service>
</services>
 
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 5

set the setting for web = LocalIS...build and run...then its working
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 390
1 Jochen Arndt 150
2 Richard MacCutchan 135
3 DamithSL 95
4 Garth J Lancaster 90
0 OriginalGriff 6,045
1 DamithSL 4,601
2 Maciej Los 4,087
3 Kornfeld Eliyahu Peter 3,480
4 Sergey Alexandrovich Kryukov 3,260


Advertise | Privacy | Mobile
Web01 | 2.8.141220.1 | Last Updated 20 Feb 2014
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100