Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C# ASP.NET MVC4
in an internet mvc 4 project, when run the project in debug mode,and login to application,the role for user wich was assigned before will recognized. the function that i use for getting user roles is :
 
System.Web.Security.Roles.GetRolesForUser(currentUser.Identity.Name)
 
but when i stop the debugging, and again run application in debug mode, user is authenticated but GetRolesForUser return string[0]. why does it occures and doesn't return role?
Posted 19-Apr-13 22:56pm
Edited 19-Apr-13 22:58pm
v2
Comments
tumbledDown2earth at 20-Apr-13 4:39am
   
did you check you web.config ?
zahra6688 at 22-Apr-13 6:16am
   
yes, i enable the rolemanager in the web.config. but i think this problem is because of using WebMatrix.webData.websecurity for managing security. it seems that it doesn't support Role managing!

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 304
1 Sergey Alexandrovich Kryukov 255
2 Shweta N Mishra 216
3 Maciej Los 210
4 PIEBALDconsult 184
0 OriginalGriff 7,630
1 Sergey Alexandrovich Kryukov 7,022
2 DamithSL 5,586
3 Manas Bhardwaj 4,946
4 Maciej Los 4,525


Advertise | Privacy | Mobile
Web01 | 2.8.1411023.1 | Last Updated 20 Apr 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100