Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
I am using Winform deployment project which uses "Provider=Microsoft.Jet.OLEDB.4.0;"as connection string
 
this works fine on 32 bit system but on 64 bit i get error saying Provider=Microsoft.Jet.OLEDB.4.0;not registered
 
I tried changing the debug to x86 from any cpu but i am still getting same issue
Posted 8-May-13 0:11am
Comments
valery possoz at 9-May-13 13:40pm
   
This question has been asked so many times... Look on google, you will se that there is no 64b version of Jet.
Look here for more details:
http://www.codeproject.com/Questions/464072/The-Microsoft-Jet-OLEDB-4-0-provider-is-not-regist
gaurish thakkar at 14-May-13 0:39am
   
i got it ..i was using a hard coded path for the database .
 
I solved it using x86 and ./ convention and using relative path .
 

thank you

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 381
1 Sergey Alexandrovich Kryukov 245
2 Marcin Kozub 225
3 Praneet Nadkar 217
4 /\jmot 189
0 OriginalGriff 8,284
1 Sergey Alexandrovich Kryukov 7,407
2 DamithSL 5,614
3 Maciej Los 4,989
4 Manas Bhardwaj 4,986


Advertise | Privacy | Mobile
Web01 | 2.8.1411023.1 | Last Updated 8 May 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100