Click here to Skip to main content
11,796,393 members (69,435 online)
Rate this: bad
Please Sign up or sign in to vote.
See more: .NET2.0 C#2.0 .NET3.0 C#3.0 C# .NET , +
I am facing an issue with the Service Agent namespace after I have get latest version of my project today morning. Previously it was working fine and also nobody has changed the service agent name.

IDE: Visual Studio 2010.

Issue: The type or namespace name MyServiceAgent does not exist in the namespace.

I have tried by deleting the agent and recreating it but no luck.

The only time it works is when I uncheck 'Reuse types' option in Configure Service Reference. But if I go ahead with this option then it creates lot of proxies classes and there will no Reusability and also class names need to be appended with namespace to avoid the 'ambigous'/conflict issues due to same types. Finally, the changes have to be done across the modules, which will take lot of time.

Kindly, I am looking forward for best possible solution to resolve this issue.

Thanks all.
Posted 20-May-13 21:50pm
Edited 21-May-13 19:02pm

1 solution

Rate this: bad
Please Sign up or sign in to vote.

Solution 1

Expert Suggestions:

Try to remove the Dependency reference Dll's. Update the Service again and restore removed dll's.

Good question Hameed.....! keep log questions.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Maciej Los 530
1 Abhinav S 392
2 OriginalGriff 340
3 CPallini 269
4 KrunalRohit 249
0 OriginalGriff 2,012
1 Maciej Los 1,725
2 KrunalRohit 1,310
3 CPallini 1,055
4 ppolymorphe 858

Advertise | Privacy | Mobile
Web04 | 2.8.151002.1 | Last Updated 22 May 2013
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100