Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: .NET2.0 C#2.0 .NET3.0 C#3.0 C# .NET , +
I am facing an issue with the Service Agent namespace after I have get latest version of my project today morning. Previously it was working fine and also nobody has changed the service agent name.
 
IDE: Visual Studio 2010.
 
Issue: The type or namespace name MyServiceAgent does not exist in the namespace.
 
I have tried by deleting the agent and recreating it but no luck.
 
The only time it works is when I uncheck 'Reuse types' option in Configure Service Reference. But if I go ahead with this option then it creates lot of proxies classes and there will no Reusability and also class names need to be appended with namespace to avoid the 'ambigous'/conflict issues due to same types. Finally, the changes have to be done across the modules, which will take lot of time.
 
Kindly, I am looking forward for best possible solution to resolve this issue.
 
Thanks all.
Posted 20-May-13 22:50pm
Edited 21-May-13 20:02pm
v3

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

Expert Suggestions:
 
Try to remove the Dependency reference Dll's. Update the Service again and restore removed dll's.
 

Good question Hameed.....! keep log questions.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 431
1 Afzaal Ahmad Zeeshan 184
2 /\jmot 176
3 Sergey Alexandrovich Kryukov 175
4 Marcin Kozub 175
0 OriginalGriff 8,344
1 Sergey Alexandrovich Kryukov 7,407
2 DamithSL 5,634
3 Maciej Los 5,024
4 Manas Bhardwaj 4,986


Advertise | Privacy | Mobile
Web03 | 2.8.1411023.1 | Last Updated 22 May 2013
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100