Click here to Skip to main content
11,709,393 members (44,200 online)
Rate this: bad
good
Please Sign up or sign in to vote.
See more: XML XNA
Good afternoon all,

I am trying to use the XmlContentImporter to populate a data structure as follows

target class object

public class UiElement
{
    public List<UiElement> Elements { get; set; }
    public Point Position { get; set; }
}

my source xml is as follows

<?xml version="1.0" encoding="utf-8" ?>
<XnaContent xmlns:UiElements="PaulsProducts.XNA.Core.Screens.UiElements">
  <Asset Type="UiElements:UiElement">
    <Position>0 0</Position>
    <Elements>
      <Item>
        <Position>0 0</Position>
        <Elements/>
      </Item>
    </Elements>
  </Asset>
</XnaContent>

This gives me the error "XML element Elements not found

Can anybody tell me what my rookie mistake is.
Posted 24-May-13 4:24am
PaulPrice2.2K

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Sergey Alexandrovich Kryukov 580
1 OriginalGriff 250
2 Maciej Los 225
3 Peter Leow 219
4 Mika Wendelius 160
0 OriginalGriff 9,428
1 Sergey Alexandrovich Kryukov 9,027
2 CPallini 5,189
3 Maciej Los 4,991
4 Mika Wendelius 3,856


Advertise | Privacy | Mobile
Web03 | 2.8.150819.1 | Last Updated 24 May 2013
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100