Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: C#
I'm having problem to run C# Form project (using Visual Studio 2008 professional edition).
 
When I try to run the project which I already ran, it says "Error while trying to run project:could not load file or assembly 'WindowsFormsApplication1' one of its dependencies. The module was expected to contain an assembly manifest".
 
After this error im not able to run any Form or any other project. Please tell me why this error occured and a way to fix this problem.
 
Thank You.
Posted 23-Mar-10 14:39pm
vigin123
Edited 23-Mar-10 15:52pm
DaveyM6977.3K
v3
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 7

Go to VS command prompt and type devenv.exe /resetskippkgs and Press Enter.
 
I hope this will solve your problem.
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

This error means that the application it's trying to run is not there. I would say this means your build failed due to an error in your code.
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 9

go to the build and click clean solutions.It worked for me.
  Permalink  
Comments
ProEnggSoft at 25-Mar-12 8:48am
   
This also worked for me in a similar situation. +5
Sourav972 at 4-Apr-12 15:02pm
   
This worked for me as well.
Great job. My +5
cogang92 at 29-Dec-12 3:10am
   
thanks.it is great
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 3

that can be caused by a software that has been installed in the computer and was corrupted.then what needs to be done is to re-install it and then start the programme again
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 6

i am geting the same problem. and i have restart and reinstall the visual studio two or three times but getting same problem as below.
 
could not load file or assembly windowsformsapplication1 or one of its dependencies. the moudle was expected to contain an assembly manifest
 
and not able to run new newly project.
 
Thanks in advance
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 8

Try reinstalling crystal report for visualstudio 2010
 
http://downloads.businessobjects.com/akdlm/cr4vs2010/CRforVS_redist_install_32bit_13_0_1.zip
 
and also add following in you appconfig
 
<startup useLegacyV2RuntimeActivationPolicy="true"></startup>
 
Take Care...
 
Çintemani IITS
  Permalink  
v2
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 15

You provided too little information to solve the problem completely, but I explained the background in my recent answer:
Error in running windows form application in vs2010 c#[^].
 
—SA
  Permalink  
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 12

restart your system and run the application therei is maximum chances that it won't show the error..
  Permalink  
Comments
SoMad at 18-Feb-13 0:33am
   
Especially since the question is 3 years old...
 
Soren Madsen
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 2

just close the application and restart vs again.
  Permalink  
Comments
mehdighazi at 11-Apr-11 4:14am
   
did not work at all .
 
i have this error still .
Bala Selvanayagam at 3-Oct-11 3:44am
   
Goto the "Build" menu anc click on the "Clean Solution" and then try buiding the application and this should work
muzaffar527 at 25-Jan-12 4:11am
   
I am facing a new problem with my project
Yesterday it worked good.. I shutdown my system and came back to my work with the project today,
it is showing the error
 
Error while trying to run project: Could not load file or assembly 'WindowsApplication1' or one of its dependencies.
The module was expected to contain an assembly manifest.
 
1. I set my project as startup project
but no use
2. Deleted the Temp folder
then also getting same error
3. I Removed all the references and added freshly
but same error exists
 

 
Now...I created a new project WindowsFormsApplication1
and placed a default empty form
 
Even if I run this simple form project, I am getting same problem
 
plz help me to solve this problem
 
I am not understanding the problem,,, wheather it is in my project or visual studio my entire one month work is seems to be gone,,,,,,,,,,,,,,,plz help me,,,,,,
Rate this: bad
good
Please Sign up or sign in to vote.

Solution 14

Set Startup Project and Start Page once again.This worked for me.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 304
1 Maciej Los 285
2 Sergey Alexandrovich Kryukov 255
3 Shweta N Mishra 216
4 PIEBALDconsult 174
0 OriginalGriff 7,660
1 Sergey Alexandrovich Kryukov 7,072
2 DamithSL 5,604
3 Manas Bhardwaj 4,986
4 Maciej Los 4,760


Advertise | Privacy | Mobile
Web02 | 2.8.1411023.1 | Last Updated 4 Jul 2014
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100