Click here to Skip to main content
11,803,019 members (64,700 online)
Rate this: bad
Please Sign up or sign in to vote.
I need to be able to play a .wmv video in a Windows Media Player component on a web page starting at a particular specified point in the video right away.

I can embed the component and play the video. The problem is that even if I specify the location with the PARAM “currentPosition”, the video starts to play from the beginning. This appears to be because the requested position in the video has not been loaded yet. If I wait until the video has been loaded to the requested position and refresh the page, it will then play from the requested position.

It seems that the video must start loading from the requested position in order to start right away. If this is the correct way, how would I go about doing it? If it is not, what is the proper way to do it? It can obviously be done, because YouTube’s players work like this.
Posted 12-May-10 22:43pm

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 OriginalGriff 335
1 KrunalRohit 291
2 F-ES Sitecore 270
3 CPallini 270
4 Sergey Alexandrovich Kryukov 234
0 OriginalGriff 2,950
1 Maciej Los 1,910
2 KrunalRohit 1,862
3 CPallini 1,735
4 Richard MacCutchan 1,157

Advertise | Privacy | Mobile
Web01 | 2.8.151002.1 | Last Updated 13 May 2010
Copyright © CodeProject, 1999-2015
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100