Click here to Skip to main content
Rate this: bad
good
Please Sign up or sign in to vote.
See more: ASP.NET MVC
I have two Edit actions in my controller. The first (top) Edit works fine and serves the correct values. However, in the second one, i.e. the 'return' Edit, every property of the model parameter is at default value, i.e. null for ref types and zero for value types. I have examined the HTTP post data and it has all the properties correctly named and with correct values. What could be wrong?
Posted 9-Jul-10 3:13am

1 solution

Rate this: bad
good
Please Sign up or sign in to vote.

Solution 1

What is the basic definition on the model, and what are the signatures on the controller actions (with attributes)?
 
If you are passing a model plus a parameter and the parameter has a name (case insensitive) that is a property this can bunge things up. The whole model won't load because there's a match on one of the params.
 
This can be a frustrating thing to debug...sometimes I just start with cutting a new view (super easy, right-click, add view).
 
With the signatures I might be able to help a bit more.
 
Cheers.
  Permalink  

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
0 Richard MacCutchan 269
1 Aajmot Sk 252
2 Marcin Kozub 235
3 Sergey Alexandrovich Kryukov 185
4 Praneet Nadkar 167
0 OriginalGriff 7,913
1 Sergey Alexandrovich Kryukov 7,232
2 DamithSL 5,604
3 Manas Bhardwaj 4,986
4 Maciej Los 4,865


Advertise | Privacy | Mobile
Web02 | 2.8.1411023.1 | Last Updated 9 Jul 2010
Copyright © CodeProject, 1999-2014
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100