Click here to Skip to main content
Click here to Skip to main content

ASP.NET MVC 4 for Visual Studio 2010 Installation Errors- incompatible with .NET 4.5 or earlier, upgrade to .NET Framework 4.5 latest version

, 27 Sep 2012
Rate this:
Please Sign up or sign in to vote.
ASP.NET MVC 4 for Visual Studio 2010 Installation Errors, 0x81f40001 - This product is incompatible with .NET 4.5 or earlier, You must upgrade to .NET Framework 4.5 to the latest version before installing this product. with Web Platform Installer and msi

Introduction 

When you install ASP.NET MVC 4 for Visual Studio 2010, If you are already using 4.5 framework in your box then you might get some strange errors. 

Background  

In my case my box was already having .NET Framework 4.5 RC and I wanted to install ASP.NET MVC 4 for Visual Studio 2010. 

I tried using the standalone installer for ASP.NET MVC 4 for Visual Studio 2010 but it throws me below error

Ohh Mad | :mad: ...Very Strange, error says that Visual Studio 2010 needs .NET Framework 4.5!. I thought it might be some problem with the standalone setup, so I though to use Web Platform Installer,

and it also given some similar error, see the screen-shot below.  

Solution 

To resolve this issue I removed the .NET Framework  4.5 RC from local box.

Visual Studio 2010 - ASP.NET MVC 4 Installation Errors- 0x81f40001 - This product is incompatible with .NET 4.5 or earlier, You must upgrade to .NET Framework 4.5 to the latest version before installing this product. Shemeer 

Wait...there is one more thing you need to do. 

Uninstalling the .NET Framework 4.5 also removes pre-existing .NET Framework 4 files. If you want to go back to the .NET Framework 4, you must reinstall it and any updates to it. 

If you are not installing .NET Framework 4.0 after uninstallation of Framework 4.5 then you will get another error saying something like 'Framework 4.0 not found". 

Please let me know if you found any other solution for this issue 

You might be interested to check Visual Studio 2010- Unknown Error after uninstallation of Framework 4.5

License

This article, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

About the Author

Shemeer NS
Software Developer (Senior)
India India
Technology Specialist | CodeProject MVP | Visual Studio Gallery Contributor | Author | Geek | Netizen | Husband | ChessPlayer
 
Most of my articles are listed on top 5 of the respective 'Best articles of the month' and some of my articles are published on ASP.NET WebSite's Article of the Day section.
 
Check my contributions in Visual Studio Gallery and Code Project
 
Technical Blog: http://www.shemeerns.com
Facebook: http://facebook.com/shemeernsblog
Twitter : http://twitter.com/shemeerns
Google+ : http://google.com/+Shemeernsblog
Follow on   Twitter   Google+

Comments and Discussions

 
Question"Ohh ...Very Strange, error says that Visual Studio 2010 needs .NET Framework 4.5!." Pinmemberstooboo28-Sep-12 0:03 
AnswerRe: "Ohh ...Very Strange, error says that Visual Studio 2010 needs .NET Framework 4.5!." PinmemberShemeer NS28-Sep-12 0:08 

General General    News News    Suggestion Suggestion    Question Question    Bug Bug    Answer Answer    Joke Joke    Rant Rant    Admin Admin   

Use Ctrl+Left/Right to switch messages, Ctrl+Up/Down to switch threads, Ctrl+Shift+Left/Right to switch pages.

| Advertise | Privacy | Mobile
Web03 | 2.8.140709.1 | Last Updated 28 Sep 2012
Article Copyright 2012 by Shemeer NS
Everything else Copyright © CodeProject, 1999-2014
Terms of Service
Layout: fixed | fluid