Click here to Skip to main content
Click here to Skip to main content

Tagged as

HTTP status 404: Not Found error while accessing WCF service through an ASMX client

, 31 Dec 2009 CPOL
Rate this:
Please Sign up or sign in to vote.
HTTP status 404: Not Found error while accessing WCF service through an ASMX clientI have personally faced this error without any accurate reasons explained in the server's log/trace. With some trial and error, I just managed to resolve it. Here is how it worked for me.Reason 1:If you...
HTTP status 404: Not Found error while accessing WCF service through an ASMX client
I have personally faced this error without any accurate reasons explained in the server's log/trace. With some trial and error, I just managed to resolve it. Here is how it worked for me.
 
Reason 1:
If you have recently modified the address of your WCF-services' basicHTTP endpoint, this new address does get updated in the client's web.config automatically by just updating the web-reference (should it not do it as it does when the web-reference ia added for the first time?). You'll need to manually update the web-reference address in the client web.config to get it working.
 
Reason 2:
If you are using the "TransportCrendentialOnly" mode at the WCF-servcie endpoint, if you can, switch to "Transport" mode, it works.
 
Helpful? Do post your resolutions, if you got any more on this problem. Thankyou. Smile | :)

License

This article, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

Share

About the Author

Karuna_Sorate
Web Developer
India India
No Biography provided

Comments and Discussions

 
-- There are no messages in this forum --
| Advertise | Privacy | Terms of Use | Mobile
Web03 | 2.8.141223.1 | Last Updated 31 Dec 2009
Article Copyright 2009 by Karuna_Sorate
Everything else Copyright © CodeProject, 1999-2014
Layout: fixed | fluid