Click here to Skip to main content
Click here to Skip to main content

Tagged as

Solving 'Activate Features' error

, 5 Feb 2013
Rate this:
Please Sign up or sign in to vote.
Solving the 'Activate Features' error.

Problem 

I was trying to make a new custom ListDefinition that's not based on content type, and when I tried to deploy, it gave the following error:

Error occurred in deployment step 'Activate Features': Cannot complete this action.  line 0 , column 0. 

Solution 

Turns out you have to remove these lines, in the ListDefinition schema file:

<ContentTypes>
  <ContentTypeRef ID="0x01">
    <Folder TargetName="Item" />
  </ContentTypeRef>
  <ContentTypeRef ID="0x0120" />
</ContentTypes> 

License

This article, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

Share

About the Author

Omar Gameel Salem
Software Developer
Australia Australia
Enthusiastic programmer/researcher, passionate to learn new technologies, interested in problem solving,data structures, algorithms and automation.
 
If you have a question\suggestion about one of my articles, or you want an algorithm implemented in C#, feel free to contact me.
Follow on   LinkedIn

Comments and Discussions

 
-- There are no messages in this forum --
| Advertise | Privacy | Mobile
Web04 | 2.8.140821.2 | Last Updated 5 Feb 2013
Article Copyright 2013 by Omar Gameel Salem
Everything else Copyright © CodeProject, 1999-2014
Terms of Service
Layout: fixed | fluid