Click here to Skip to main content
11,648,960 members (76,224 online)
Click here to Skip to main content

Solving the "Unable to Connect to the MDS Simulator Service" problem in Blackberry Simulators

, 8 Jul 2010 CPOL 8.5K 1
Rate this:
Please Sign up or sign in to vote.
This tip describes a way to solve a problem that occurs in BB simulators
Earlier, I was working in developing a mobile .Net web application and had to test the same in a Blackberry Simulator. The first time I started trying out, it was a breeze, the page opened up and I was able to browse the web site. But the next time I fired up my browser from the simulator, nothing seemed to work. I was getting the following error every time I fired up my brower (my MDS was up and running).

"Unable to connect to the selected mobile data service..."



I tried in vain to solve this problem by various means, but nothing seemed to work. So I set out googling and found no posts regarding this. Finally I found a post that was discussing about launching the simulator from the command line. I used some of the command line parameters described in that post and at last, I was successfully able to get it working again! Let me get to the part where I describe how the issue could be solved.

Say, you are running the 9530 simulator (BB JDE version 4.7.0). Open the "9530.bat" file that launches the 9530 version of the simulator. These batch file(s) would be located in application directory's simulator folder or in the directory where you installed the simulator. Open up this file in notepad

e.g.

@echo off 
fledge.exe /app=Jvm.dll /handheld=9530 /session=9530 /app-param=DisableRegistration /app-param=JvmAlxConfigFile:9530.xml /data-port=0x4d44 /data-port=0x4d4e /pin=0x2100000A

Add the attribute /clear-flash after /pin=0x2100000A (i.e. towards the end of the file). So the modifed batch file would look like:

@echo off 
fledge.exe /app=Jvm.dll /handheld=9530 /session=9530 /app-param=DisableRegistration /app-param=JvmAlxConfigFile:9530.xml /data-port=0x4d44 /data-port=0x4d4e /pin=0x2100000A /clear-flash

Now try launching the simulator and you should not be facing this problem again.

License

This article, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

Share

About the Author

Karthik. A
Software Developer
United States United States
Just another passionate software developer! I recently acquired my MCTS Wink | ;)

My latest contribution to the open source world is a blog engine written in MVC 3 - sBlog.Net. Check it out here. For the codeproject article regarding sBlog.Net click here!

I have recently (re)launched my web-site. Check it out at http://thekfactor.info!

Eventually, I have a blog under my own sub-domain. It is http://blog.thekfactor.info

Also check out my latest app - directory comparer [codeproject article and dedicated site] and my latest jquery plugin - partial collapsible panel!!!


All sites were developed in ASP.Net MVC 2 Smile | :)


You may also be interested in...

Comments and Discussions

 
-- There are no messages in this forum --
| Advertise | Privacy | Terms of Use | Mobile
Web03 | 2.8.150804.4 | Last Updated 8 Jul 2010
Article Copyright 2010 by Karthik. A
Everything else Copyright © CodeProject, 1999-2015
Layout: fixed | fluid