Click here to Skip to main content
15,041,525 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi All Again.

as the title says.
it just started happening this morning, but it seams to do it on just that one solution.

but i dont want to recreate the solution( but may do just to see if that fixes it ).

what could cause this ?
i tried adding a dummy win32 console app in to see if it was just the one project, but it also hanges the IDE.

any suggestions ?

Thanks in Advance.

I'd try a couple of things:

1) Disable all extensions/addons (Power Tools, Resharper, etc.) and try it.

2) Put a breakpoint at the very start of your program (your program's entry point - ex. Main) and see if it reaches there.

3) Recreate the solution and see if that fixes it. If it does, do a diff between the two and see where they differ. It won't be pretty but it'd be good to know why it is hanging up.

4) If you use source control, roll back a few days and see if it continues to exist.
Albert Holguin 21-Oct-11 14:37pm
OP posted as solution:
@Andrew Rissing
Good Points

The new project option works right.

i tried deleting the .suo file fixed the problem( at least for now )
it appears that a large suo file can cause VS to hang( mine was at 3MB ).
Albert Holguin 21-Oct-11 14:38pm
Sorry Andrew, deleted your comment to him when I deleted his comment... I saw your comment pop-in right when I deleted the post. +5
Andrew Rissing 21-Oct-11 16:23pm
Np, I should have just commented on the original question. No biggie. Thanks for the +5 :)
ryan20fun 22-Oct-11 1:45am
Thanks :-)
ryan20fun 22-Oct-11 1:42am
Thanks :-)
After a lot of cussing, I figured out my problem...don't know if this helps someone else, but I made the mistake of installing Google Earth. This automatically installed the ASK tool bar, the bane of my existence. I tried uninstalling and disabling this addon but alas, it came back to me like an boomerang. I finally executed a tool on the ASK toolbar FAQ that probably removed remaining remnants of the Ask toolbar from my registry. Now my debug sessions don't hang indefinitely or fail, and debugging my web apps is a lot less frustrating.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900