Click here to Skip to main content
14,696,452 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
We have Classic ASP script which run on windows 2003 / SQL Server 2000 / SQLXMLOLEDB.3.0 ...

Recently we changed host. Now when we try to execute our script we get following error message .

Our connection string is
str = "Provider=SQLXMLOLEDB.3.0;Data Provider=SQLOLEDB;Initial Catalog=XXX;data source=XXXX;User ID=sa;Password=sa;"


ADODB.Connection error '800a0e7a'

Provider cannot be found. It may not be properly installed.


Pl help me...

Thanks in advance!!!!
Posted

1 solution

Sounds like the provider isn't installed on the host you have moved to


http://www.connectionstrings.com/Providers/sqlxml-3-0-oledb-provider[^]

Do you have to use that provider? Maybe try a different connection string, e.g

http://www.connectionstrings.com/sql-server#p6[^]
   
Comments
nitintfs 31-May-12 10:37am
   
Thanks for your immediate response...

For your reference my code something similar to the link below but it is developed using Classic ASP instead of VB -
http://msdn.microsoft.com/en-us/library/aa258684%28v=sql.80%29.aspx
Dylan Morley 31-May-12 10:44am
   
Ah I see - you may need to contact your new host support department and ask them about that provider
nitintfs 31-May-12 10:57am
   
It is VPS server and I have installed all necessary components - SQLXMLOLEDB.3.0 ...

What could be the solution for this ?

Please help me..
nitintfs 31-May-12 10:59am
   
I found one more link -
http://community.discountasp.net/showthread.php?t=2017

please see comments / sample code posted by Bruce.

My application similar to sample code by Bruce ...

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900