Click here to Skip to main content
14,766,562 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
Hi Please see whether I'm right. A company claims that its cameras are Profile T compliant. So I visit this document to see what functions the cameras supports. In section 7.2.3 I see the function list for devices. I examine the first one, GetServices with the following command:

curl -d '<?xml version="1.0" encoding="utf-8"?><soap12:Envelope xmlns:xsi="" xmlns:xsd="" xmlns:soap12=""><soap12:Body><GetServices xmlns="Battle of the Bulge, 75 years on" /></soap12:Body></soap12:Envelope>'

The camera responds:
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="" xmlns:SOAP-ENC="" xmlns:xsi="" xmlns:xsd="" xmlns:c14n="Exclusive XML Canonicalization Version 1.0" xmlns:wsu="" xmlns:ds="XML-Signature Syntax and Processing" xmlns:tt="" xmlns:tns1="" xmlns:xmime="" xmlns:xop="" xmlns:wsa="WS-Addressing 1.0 Namespace" xmlns:wsrfr="" xmlns:wsrfrw="" xmlns:wsrfbf="" xmlns:wstop="" xmlns:wsse="" xmlns:wsnt="" xmlns:dn="" xmlns:tan="" xmlns:tds="" xmlns:tev="" xmlns:timg="" xmlns:tptz="" xmlns:trt="" xmlns:tmd="" xmlns:ter="" xmlns:tavg="" xmlns:tnsavg="" xmlns:avg="" xmlns:avgb="" xmlns:d="Web Services Dynamic Discovery (WS-Discovery)"><SOAP-ENV:Body><SOAP-ENV:Fault SOAP-ENV:encodingStyle=""><SOAP-ENV:Code><SOAP-ENV:Value>SOAP-ENV:Sender</SOAP-ENV:Value></SOAP-ENV:Code><SOAP-ENV:Reason><SOAP-ENV:Text xml:lang="en">Method 'GetServices' not implemented: method name or namespace not recognized</SOAP-ENV:Text></SOAP-ENV:Reason></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>

It says that the method is not implemented. Whatever I've examined until now got the same response. So I wonder maybe I've some mistakes in my requests.
Any idea?

What I have tried:

I've tries other functions too and all of them give the same result. Just GetSystemDateTime web service could return a value.
Updated 31-Jul-20 7:46am
Patrice T 15-Dec-19 0:49am
Why don't you ask the vendor ?
ilostmyid2 15-Dec-19 8:09am
The vendor tells it's Onvif compliant and you're enough to search in that site!

You should talk to the people who created it - they should provide technical support and will know more about their product than we will. If they don't, then find another supplier and demand your money back!

We can't help you, we don't even know which camera you are talking to!
ilostmyid2 15-Dec-19 8:18am
Software that use Onvif to communicate with cameras may get motion from this camera too, like Onvif Device Manager. So the problem is out of the camera itself. So I think I should figure my problem out by relying on the Onvif site and documents and asking others who may be more familiar with the protocol. If you need to know the brand, it's an Avigilon camera.
The correct way to specify the operation is
<wsdl:GetServices xmlns:wsdl="">

(the namespace definition can be moved to the Envelope tag, with the other namespaces)

Full explanation is on stackoverflow

onvif - I get 'not implemented' response - Stack Overflow[^]

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900