Click here to Skip to main content
14,775,325 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
Could not load file or assembly 'file:///F:\Program Files\SAP BusinessObjects\Crystal Reports for .NET Framework 4.0\Common\SAP BusinessObjects Enterprise XI 4.0\win32_x86\dotnet1\crdb_adoplus.dll' or one of its dependencies. The system cannot find the file specified.


What I have tried:

con.Open();
            cry.Load(@"D:\Cart\sample\StockManagmentSystem\StockManagmentSystem\Reports\Product.rpt");
            Data.DataSet1 ds = new Data.DataSet1();
            SqlDataAdapter adp = new SqlDataAdapter("select * from tblProduct", con);
            DataTable dt = new DataTable();
            adp.Fill(dt);
            cry.SetDataSource(dt);
            crystalReportViewer1.ReportSource = cry;
            crystalReportViewer1.Refresh();
            con.Close();
Posted
Updated 12-Apr-20 20:56pm

You could try using useLegacyV2RuntimeActivationPolicy as mentioned here: c# - Could not load file or assembly crdb_adoplus.dll - Stack Overflow[^]
   
Comments
Member 11297177 13-Apr-20 1:58am
   
after refer your link , worked fine thanks a lot
after refer the above link it works fine, thank you for support
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900