Click here to Skip to main content
15,041,391 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I'am trying to install twilio from Package Manager Console but it getting me this error
any help please?

What I have tried:

<pre>PM> Install-Package Twilio -Version 5.28.0
Attempting to resolve dependency 'JWT (≥ 1.3.4)'.
Install-Package : 'Twilio' already has a dependency defined for 'Microsoft.IdentityModel.Tokens'.
At line:1 char:1
+ Install-Package Twilio -Version 5.28.0
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
Posted
Updated 8-Jun-20 4:25am

Usually a re-install of the NuGet Package Manager clears this problem up
VS Marketplace: NuGet Package Manager[^]
   
Comments
Rajaa Khalifeh 6-Jun-20 12:06pm
   
how can I un-install NuGet and then re-install it again ?
Rajaa Khalifeh 7-Jun-20 7:19am
   
it also doesn't work with me is their any other way please?
You are trying to install a really old version of the package - 5.28.0 was released last March. The current version is 5.42.0 and it doesn't have a dependency on Microsoft.IdentityModel.Tokens.

(Actually, it does still have the dependency. It would help if I looked at the right target framework! 🤦‍♂️)

NuGet Gallery | Twilio 5.42.0[^]
   
v2
Comments
Rajaa Khalifeh 10-Jun-20 6:33am
   
okay so how can I fix this ?
Richard Deeming 10-Jun-20 6:34am
   
Install the newer version.
Rajaa Khalifeh 10-Jun-20 6:40am
   
Install-Package Twilio -Version 5.42.0
Attempting to resolve dependency 'JWT (≥ 1.3.4)'.
Install-Package : 'Twilio' already has a dependency defined for 'Microsoft.IdentityModel.Tokens'.
At line:1 char:1
+ Install-Package Twilio -Version 5.42.0
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException
+ FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

Same error :(
Richard Deeming 10-Jun-20 6:45am
   
Try updating the NuGet package manager to the latest version:
How to upgrade nuget with Visual Studio Express 2012 - Stack Overflow[^]

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900