Click here to Skip to main content
15,037,009 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
NullReferenceException: Object reference not set to an instance of an object
MultipelCamera.Zoom () (at Assets/MultipelCamera.cs:36)
MultipelCamera.LateUpdate () (at Assets/MultipelCamera.cs:30)

What I have tried:

using System.Collections;
using System.Collections.Generic;
using UnityEngine;

public class MultipelCamera : MonoBehaviour
    public List<Transform> targets;
    public Vector3 offset; 
    public float smoothTime = .5f;
    public float minZoom = 40f;
    public float maxZoom = 10f;
    public float zoomLimiter = 50f;
    private Camera cam;

    private Vector3 velocity;

    void start()
        cam = GetComponent<Camera>();

   void LateUpdate()
        if (targets.Count == 0)


    void Zoom()
        float newZoom = Mathf.Lerp(maxZoom, minZoom, GetGreatestDistance() / zoomLimiter);
        cam.fieldOfView = Mathf.Lerp(cam.fieldOfView, newZoom, Time.deltaTime); 
    float GetGreatestDistance()
        var bounds = new Bounds(targets[0].position,;
        for (int i = 0; i < targets.Count; i++)
        return bounds.size.x;

    void move()
        Vector3 centerPoint = GetCenterPoint();
        Vector3 newPosition = centerPoint + offset;
        transform.position = Vector3.SmoothDamp(transform.position, newPosition, ref velocity, smoothTime);

    Vector3 GetCenterPoint()
        if (targets.Count == 1)
            return targets[0].position;

        var bounds = new Bounds(targets[0].position,;
        for (int i = 0;i < targets.Count; i++)

Updated 11-Jun-21 20:35pm

This is one of the most common problems we get asked, and it's also the one we are least equipped to answer, but you are most equipped to answer yourself.

Let me just explain what the error means: You have tried to use a variable, property, or a method return value but it contains null - which means that there is no instance of a class in the variable.
It's a bit like a pocket: you have a pocket in your shirt, which you use to hold a pen. If you reach into the pocket and find there isn't a pen there, you can't sign your name on a piece of paper - and you will get very funny looks if you try! The empty pocket is giving you a null value (no pen here!) so you can't do anything that you would normally do once you retrieved your pen. Why is it empty? That's the question - it may be that you forgot to pick up your pen when you left the house this morning, or possibly you left the pen in the pocket of yesterday's shirt when you took it off last night.

We can't tell, because we weren't there, and even more importantly, we can't even see your shirt, much less what is in the pocket!

Back to computers, and you have done the same thing, somehow - and we can't see your code, much less run it and find out what contains null when it shouldn't.
But you can - and Visual Studio will help you here. Run your program in the debugger and when it fails, VS will show you the line it found the problem on. You can then start looking at the various parts of it to see what value is null and start looking back through your code to find out why. So put a breakpoint at the beginning of the method containing the error line, and run your program from the start again. This time, VS will stop before the error, and let you examine what is going on by stepping through the code looking at your values.

But we can't do that - we don't have your code, we don't know how to use it if we did have it, we don't have your data. So try it - and see how much information you can find out!
Blank Channel 12-Jun-21 2:51am
Thank man, you really made a pretty good explanation. My problem is solved too, thank again.
OriginalGriff 12-Jun-21 3:29am
You're welcome!
Describe the context here: is this a Unity app, or, are you controlling some device that exposes an API ? Where is Mathf.Lerp defined ?

Add tags to your question to help readers quickly know what the context is.

Can't say much based on this code fragment. You need to set a breakpoint at the start of each method, then single-step through the code (F11), examine the value/state of variables and parameters, and isolate exactly where the error occurs.
Blank Channel 12-Jun-21 1:24am
I added what you said, I am not sure some of my code cause I have to make quick camera script so I don't understand some codes fully yet. Please help me.
Blank Channel 12-Jun-21 2:53am
Thank man I solve that now.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900