Click here to Skip to main content
12,954,464 members (77,920 online)
Rate this:
Please Sign up or sign in to vote.
See more:

We are working on an application which generates an MS word document and opens in the client machine where users can edit and save in the same server using Impersonation.

It worked in test environment but when moved to production it is giving problems.
When we logged into server generates a word document through UI and it is working fine but when we logged off from server it is throwing below exception.

Word experienced an error trying to open the file.
Try these suggestions.
* Check the file permissions for the document or drive.
* Make sure there is sufficient free memory and disk space.
* Open the file with the Text Recovery converter.

Can any one help this how to solve the above issue.
Posted 16-Mar-13 2:40am
Updated 16-Mar-13 3:57am
Mike Meinz26.5K
ThePhantomUpvoter 16-Mar-13 9:24am
Okay first thing you need to do is: Check the file permissions for the document or drive
#2 Make sure there is sufficient free memory and disk space
#3 Open the file with the Text Recovery converter
#4 Debug your code
#5 Don't use Office products in unsupported configurations.
Prashant Bangaluru 20-Mar-13 5:41am
Hi ,Thanks for your reply I checked the file permission and memory they are as in the test envi.
The only prob is when we log into server and try to generate it is working but we log off it is failing to regenerate.

1 solution

Rate this: bad
Please Sign up or sign in to vote.

Solution 1

Your impersonated user(register either web.config or other way) has not proper permission in that directory in your production server. You just assign appropriate permissions to that directory to the impersonate user.
Prashant Bangaluru 20-Mar-13 5:37am
Hi ,Thanks for your reply We mentioned the user id and password in web.config but no use.Checked all file permission to the directory ,directory has got all the permissions I tried all the above options but not working..
S. M. Ahasan Habib 20-Mar-13 6:17am
You set full permissions to Everyone(default user/group) at your directory and check it is working or not.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

    Print Answers RSS
Top Experts
Last 24hrsThis month
OriginalGriff 6,524
CHill60 3,490
Maciej Los 3,123
ppolymorphe 2,030
Jochen Arndt 1,975

Advertise | Privacy | Mobile
Web01 | 2.8.170525.1 | Last Updated 16 Mar 2013
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100