Click here to Skip to main content
12,632,072 members (26,928 online)
Click here to Skip to main content
Add your own
alternative version

Stats

19.7K views
12 bookmarked
Posted

Naming Conventions: Grouping within a Class

, 25 Jul 2008 CPOL
Rate this:
Please Sign up or sign in to vote.
We provide a challenge to conventional wisdom of verb first to aid in grouping of names.

Introduction

A common practice when selecting a naming convention is to use verb first resulting in names that read like an English phrase like GetThisThing. While establishing and sticking with a naming convention is wise, other factors are presented that may prove helpful, especially grouping concerns.

Although English words are used as the structure of virtually all programming languages, not all developers speak English as their native tongue. Non-English developers will frequently use English terms for their public classes and may go as far as commenting their code in English.

However the English sentence structure may not be the best when we are attempting to form a valuable descriptive phrase. We should consider the benefits of different sentence structures, most notably the position of the verb, when we form names.

If we have a class that has a value that we need to get, set and toggle we might have functions GetThisThing, SetThisThing and ToggleThisThing. We write our class with our three functions plus 38 more. A month later when it is no longer fresh in our minds, or when Joe Developer in the other department needs to make use of our class and work with an instance of ThisThing it is natural to use IntelliSense to find the functions we need.

We can assume that if we start typing .g that IntelliSense will quickly get us to the GetThisThing function. The same is true for our set function. However, since we don't remember or are not familiar with the code, we may not know that there is a toggle function that we require and end up doing the get, toggle, set sequence ourselves. IntelliSense will show us the toggle function, but not until we start with .t. When there are a lot of functions in our class, we are unlikely to notice it.

If we put the verb on the end, our function names would be ThisThingGet, ThisThingSet, ThisThingToggle. Now when we are working with an instance of the class and we need to work with ThisThing and we start typing .t we end up with all of our functions that address ThisThing together.

The use of namespaces allows us to group functional areas together which aids in code manageability. Grouping functions within a class by beginning names with its group accomplishes the same for a class.

We need to balance readability in an English sense and usability from a developer’s perspective. After all, the code is intended to be read by developers and not a general audience.

History

  • 25th July, 2008: Initial post

License

This article, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

Share

About the Author

ShofarNexus
Founder ShofarNexus Corporation
United States United States
ShofarNexus™ is software project started in 1998 with a lot of testing and rejecting of methodologies. Our goals were fast startup and execution, a clean presentation and reliable data distribution. We take ReST to the extreme. We focus some on eye-candy and mostly on the meat and vegetables that are good for business.

ShofarNexus™ mentality is well described by Antoine de Saint-Exupéry who wrote “Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.”

ShofarNexus™ is single-handedly written by John Kozlowski, with over 35 years of software development experience and a lot of hardware design in the first two decades.

You may also be interested in...

Pro

Comments and Discussions

 
QuestionWhy not make the article a forum post and add something useful? Pin
Dave Jellison26-Jul-08 14:42
memberDave Jellison26-Jul-08 14:42 
AnswerRe: Why not make the article a forum post and add something useful? Pin
emilio_grv27-Jul-08 7:11
memberemilio_grv27-Jul-08 7:11 
GeneralRe: Why not make the article a forum post and add something useful? Pin
Dave Jellison27-Jul-08 7:52
memberDave Jellison27-Jul-08 7:52 
GeneralRe: Why not make the article a forum post and add something useful? Pin
DirectorWare28-Jul-08 7:55
memberDirectorWare28-Jul-08 7:55 
As mentioned in both some of the feedback as well as the article itself, there is wisdom in defining and sticking with a naming convention. Depending on the size of the team and the personalities involved, change or flexibility in the standards is acceptable. Especially the case of the small shop or individual, sudden reasoned change can be beneficial, whereas whimsical change can be simply change for the sake of change which produces nothing.

Regions have been mentioned as something desired by some, but I have heard of many, including myself, that loath them. Much of this is taste and I can accept those who have preferences that I do not have, just as it is acceptable if you like contemporary music while I like classical.

Personally rather than using regions, I make heavy use of partial classes and separate logical segments of a class into physically separate files. This allows particular segments to naturally appear in separate tabs and be instantly visible in the file tree. For example I might have Class.cs and Class.Xml.cs to separate XML serialization methods.

The bottom line is that software remains an art that includes a variety of styles. Arguments as to which is better, VB or C#, are frequently laced with personal preferences and prejudices, rather that reasoned assertions. An attempt was made in the article to make a reasoned assertion, but admittedly since it is now the technique used at DirectorWare, there is now a preference for it.
GeneralRe: Why not make the article a forum post and add something useful? Pin
Dave Jellison28-Jul-08 8:25
memberDave Jellison28-Jul-08 8:25 
GeneralRe: Why not make the article a forum post and add something useful? Pin
DirectorWare28-Jul-08 9:13
memberDirectorWare28-Jul-08 9:13 
QuestionWhy voting 1 ? Pin
emilio_grv25-Jul-08 22:36
memberemilio_grv25-Jul-08 22:36 
AnswerRe: Why voting 1 ? Pin
DirectorWare26-Jul-08 8:50
memberDirectorWare26-Jul-08 8:50 

General General    News News    Suggestion Suggestion    Question Question    Bug Bug    Answer Answer    Joke Joke    Praise Praise    Rant Rant    Admin Admin   

Use Ctrl+Left/Right to switch messages, Ctrl+Up/Down to switch threads, Ctrl+Shift+Left/Right to switch pages.

| Advertise | Privacy | Terms of Use | Mobile
Web01 | 2.8.161208.2 | Last Updated 25 Jul 2008
Article Copyright 2008 by ShofarNexus
Everything else Copyright © CodeProject, 1999-2016
Layout: fixed | fluid