Click here to Skip to main content
14,334,621 members
   

ASP.NET

 
QuestionInsert HTML Elements In A DIV In VB WebForm Dynamically Using jQuery Pin
MadDashCoder30-Nov-18 19:15
memberMadDashCoder30-Nov-18 19:15 
AnswerRe: Insert HTML Elements In A DIV In VB WebForm Dynamically Using jQuery Pin
F-ES Sitecore2-Dec-18 23:02
mveF-ES Sitecore2-Dec-18 23:02 
QuestionHaving difficulty with an MVC question Pin
Member 1406015930-Nov-18 7:25
memberMember 1406015930-Nov-18 7:25 
AnswerRe: Having difficulty with an MVC question Pin
Dave Kreskowiak30-Nov-18 7:59
mveDave Kreskowiak30-Nov-18 7:59 
GeneralRe: Having difficulty with an MVC question Pin
Member 1406015930-Nov-18 8:31
memberMember 1406015930-Nov-18 8:31 
GeneralRe: Having difficulty with an MVC question Pin
Richard MacCutchan30-Nov-18 22:25
protectorRichard MacCutchan30-Nov-18 22:25 
GeneralRe: Having difficulty with an MVC question Pin
Vincent Maverick Durano5-Dec-18 15:07
mveVincent Maverick Durano5-Dec-18 15:07 
QuestionDebugging a Web API Project in Visual Studio 2017 Pin
Dominick Marciano26-Nov-18 5:13
professionalDominick Marciano26-Nov-18 5:13 
I currently have a solution which contains two projects: an ASP.NET site and a Web API project. On the site, I have a page that is meant to call the API using the POST method at address http://localhost:52855/api/v1/GetPrices asynchronously (e.g. response = await base.SendAsync(request, cancellationToken where "base" is a DelegatingHandler). Part of the data that is posted is an API key along with a signature to ensure the user is authorized. However, nothing happens; the Chrome tab just shows the loading symbol continuously.

But, if I use Fiddler and make a POST request to the same address (http://localhost:52855/api/v1/GetPrices), but without the API/signature information, I get back the correct response - a 401 Unauthorized and a "WWW-Authenticate: amx" header (where "amx" is the authentication scheme I'm using for testing. If I include the authorization header in Fiddler then I get a 500 Internal Server Error

My biggest question is how can I debug the Web API project in Visual Studio 2017 Enterprise edition? I have breakpoints set on all the methods (e.g. the Post method in my GetPricesController : ApiController as well as my HMACAuthenticationAttribute which implements the IAuthenticationFilter). I feel that if I can at least start seeing what's going on when I make the requests with Fiddler, that I may be able to figure out the web app from there.

I'm supposed to be doing a demo on this Web API project tomorrow early afternoon and I've been working for the back 11 hours on finishing this up but I'm completely stalled now and have no idea where to go from here. Any help/guidance would be so greatly appreciated. Thank you.

P.S. I was using this article http://bitoftech.net/2014/12/15/secure-asp-net-web-api-using-api-key-authentication-hmac-authentication/ to implement the API key validation.
A black hole is where God tried to divide by zero.

There are 10 kinds of people in the world; those who understand binary and those who don't.

AnswerRe: Debugging a Web API Project in Visual Studio 2017 Pin
maryam.saboor4-Dec-18 23:36
professionalmaryam.saboor4-Dec-18 23:36 
QuestionHow to write Edit Item template in asp.net with sql command Pin
Member 1362771923-Nov-18 22:19
memberMember 1362771923-Nov-18 22:19 
QuestionList is losing it's contents ? Pin
caffrey_123-Nov-18 2:37
membercaffrey_123-Nov-18 2:37 
AnswerRe: List is losing it's contents ? Pin
Richard MacCutchan23-Nov-18 2:46
protectorRichard MacCutchan23-Nov-18 2:46 
GeneralRe: List is losing it's contents ? Pin
caffrey_123-Nov-18 3:01
membercaffrey_123-Nov-18 3:01 
AnswerRe: List is losing it's contents ? Pin
Richard Deeming23-Nov-18 3:32
mveRichard Deeming23-Nov-18 3:32 
GeneralRe: List is losing it's contents ? Pin
caffrey_123-Nov-18 4:05
membercaffrey_123-Nov-18 4:05 
GeneralRe: List is losing it's contents ? Pin
Richard Deeming23-Nov-18 4:13
mveRichard Deeming23-Nov-18 4:13 
GeneralRe: List is losing it's contents ? Pin
caffrey_123-Nov-18 4:45
membercaffrey_123-Nov-18 4:45 
QuestionRDLC Report is not showing Column Headers in all the pages Pin
simpledeveloper20-Nov-18 14:30
membersimpledeveloper20-Nov-18 14:30 
AnswerRe: RDLC Report is not showing Column Headers in all the pages Pin
Richard Deeming21-Nov-18 8:07
mveRichard Deeming21-Nov-18 8:07 
QuestionCSV and WordPress Pin
Davstr19-Nov-18 13:23
memberDavstr19-Nov-18 13:23 
AnswerRe: CSV and WordPress Pin
Mycroft Holmes20-Nov-18 11:16
memberMycroft Holmes20-Nov-18 11:16 
QuestionKilling a remote application browser session from a new browser session. Pin
holdorf18-Nov-18 4:22
memberholdorf18-Nov-18 4:22 
AnswerRe: Killing a remote application browser session from a new browser session. Pin
Richard Deeming19-Nov-18 3:00
mveRichard Deeming19-Nov-18 3:00 
QuestionoData request to REST server Pin
RVMRVM17-Nov-18 8:48
memberRVMRVM17-Nov-18 8:48 
QuestionRe: oData request to REST server Pin
Richard MacCutchan17-Nov-18 21:09
protectorRichard MacCutchan17-Nov-18 21:09 

General General    News News    Suggestion Suggestion    Question Question    Bug Bug    Answer Answer    Joke Joke    Praise Praise    Rant Rant    Admin Admin   

Use Ctrl+Left/Right to switch messages, Ctrl+Up/Down to switch threads, Ctrl+Shift+Left/Right to switch pages.