Click here to Skip to main content
15,884,836 members
Please Sign up or sign in to vote.
1.00/5 (2 votes)
See more:
Hello! Im doing a programming challenge and the challenge is:

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

Emergency 911
Alice 97 625 999
Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input
The first line of input gives a single integer, 1≤t≤40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1≤n≤10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample input:
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample output:
NO
YES

My code is:
C#
public class Program
   {
     static List<string> testList = new List<string>();

       static void Main(string[] args)
       {
           validateTestCases(getAllPhoneNumbers());
       }

       public static List<string> getAllPhoneNumbers()
       {
          List<string> phoneList = new List<string>();
           string input;
           while ((input = Console.ReadLine()) != null && input != "")
           {
               phoneList.Add(input);
           }
           return phoneList;
       }

       public static void validateTestCases(List<string> inputList)
       {
           int numbersOfPhoneNumbers;
           for (int i = 1; i < inputList.Count; i++)
           {
               numbersOfPhoneNumbers = Convert.ToInt32(inputList[i]);
               for (int j = i + 1; j <= i + numbersOfPhoneNumbers; j++)
               {
                   testList.Add(inputList[j]);
                   if (j == (i + numbersOfPhoneNumbers))
                   {
                       checkPrefixes(testList);
                   }
               }
               i = i + numbersOfPhoneNumbers;
           }
       }


       public static void checkPrefixes(List<string> input)
       {
           for (int i = 0; i < input.Count; i++)
           {
               for (int j = 0; j < input.Count; j++)
               {
                   if (input[i].StartsWith(input[j]) && i != j)
                   {
                       Console.WriteLine("NO");
                       testList.Clear();
                       return;
                   }
               }
           }
           testList.Clear();
           Console.WriteLine("YES");
       }

   }


The answser seems to be right but my soultion excedes the time limit witch is 4 secounds? How can i make it run faster? Would pasting in all the code in the main help? Appriciate all Anwsers! :)
Posted
Comments
Sascha Lefèvre 12-Jun-15 5:58am    
- Is your program supposed to read the phone numbers from the console?

- You have four nested for-loops. That's no good - probably the reason why your program is slow. Try to find a way that doesn't require so much looping.
Amarnath S 12-Jun-15 5:59am    
What will be my prize, if I win?
[no name] 12-Jun-15 6:06am    
Overclocking?

1 solution

This is a coding challenge - a competition.
That means it's up to you to find a solution which works and fits the parameters of the challenge.

Us telling you what to do isn't fair on any others trying, is it? This is supposed to be about your coding abilities, not ours! And this is your third try to get challenge solutions...

Give it a try yourself: it might make you a better programmer than if we handed you a solution...
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900