Click here to Skip to main content
15,748,973 members
Please Sign up or sign in to vote.
1.00/5 (1 vote)
See more:
After I installed IE 11 to substitute IE 9, I can't run debugging on the code in my VS 2010 project. Then, I changed the default browser to another one (not IE), the file still can't be attached to VS for debugging. How to fix it? Thanks.
Updated 1-Jul-15 6:19am
Sergey Alexandrovich Kryukov 1-Jul-15 11:50am    
VS always had some problems with JavaScript debugging support, when you change the browser. Dig into VS settings. It can be fixed, but not so easily. I even managed to support "foreign" browsers, but it's hard to remember...
s yu 1-Jul-15 12:40pm    
I tested the procedure below. It works now:
1) In VS 2010, set IE as Default browser.
2) In VS 2010, Ctrl-Alt + P to ope Attach to Process Wizard.
3) Highlight on iexplore.exe, and in Attach: select Script.
4) Start debugging.

Sergey Alexandrovich Kryukov 1-Jul-15 12:43pm    
Very good.
Sreekanth Mothukuru 2-Jul-15 4:56am    
Do we need to change any IE internet options? Like in advance tab we have "Disable script debugging" (IE and other) option?

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900