Click here to Skip to main content
14,271,663 members

Rookie website mistake?

dnibbo asked:

Open original thread
OK, this is odd and I am sure I have forgotten something very basic here but...

I created and published a new website using VS2010 with a 'place holder' home page (Home.html) which is so basic it is untrue.
I have set this as the start page in my project and tested it in local-host and the 'Place holder' page renders just fine.
I have published it to our IIS server and when I go to http://url/page.html it works but when I go to http://url/ I get an error 404 page does not exist.

What stupid error have I made? It is set as the start up page in the project.
I have added it as a default document in IIS also even though I don't think I needed to.

I maintain lots of websites but this is the first new one I have published for a while... someone help a forgetful old fool out...!

Thanks
Tags: HTML, ASP

Preview



When answering a question please:
  1. Read the question carefully.
  2. Understand that English isn't everyone's first language so be lenient of bad spelling and grammar.
  3. If a question is poorly phrased then either ask for clarification, ignore it, or edit the question and fix the problem. Insults are not welcome.
  4. Don't tell someone to read the manual. Chances are they have and don't get it. Provide an answer or move on to the next question.
Let's work to help developers, not make them feel stupid.
Please note that all posts will be submitted under the The Code Project Open License (CPOL).




CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100