Click here to Skip to main content
14,977,259 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
I have published a web application in asp.net using Visual Studio 2012 using web deploy... The publish was succeeded and after that when I entered localhost/Sitename in the browser it shows 404 error... What are the steps to be done in IIS to prevent this error...

What I have tried:

I have looked at the IIS but can't understand anything
Posted
Comments
[no name] 14-Mar-16 5:12am
   
Make sure that you are browsing correct directory with correct file name.
Just cross check whether the virtual directory created successfully in IIS.
Go to IIS and see the website you created. Then try to browse on right click of the the files in IIS.
SajinAboo 14-Mar-16 5:36am
   
I can see the files of the application inside the IIS, but when I browse it show 404 error... Can you tell me what are the steps that is needed to be done in the IIS after I have published the application in Visual Studio 2012...???
Serkan Onat 14-Mar-16 8:29am
   
it depends which steps you made so far

it might be a write permission issue
or Enable 32Bit driver on 64Bits issue
it might be your browser, (as i have experienced an issue with an old version of FireFox (trust local URLs))
and list goes so
if you have no idea about IIS configuration
you would better follow some getting started tutorials here:

http://www.iis.net/

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900