Click here to Skip to main content
15,793,546 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I'm pretty new to the and sql. I made a website which uses an sql database as its backend. I publish it on IIS and the database runs. However when i upload the files from the root folder to the website root folder, the pages where the database runs display error;


You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

i tried to look for the answer on the net and even asked other people around but i still can't get a clear picture.

i'm using 2015 framework 4.0, with sqlexpress and IIS 7.5

can anyone tell me what the problem is, or if i committed any misstep during publish or deploying stage?

What I have tried:

i tried using both sqlexpress and sql local db...
i tried uploading the files from root folder of my machine to the root of the remote server.
Sinisa Hajnal 22-Mar-16 3:19am    
You have to be able to copy files to target (server) folder. Then you have to see what rights your application needs on the server (i.e. if you're writing to some config file, you have to have write rights FOR YOUR APPLICATION ACCOUNT, not your own.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900