Click here to Skip to main content
15,900,511 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
C#
bash: export: `Files/Skype/Phone:/c/Program': not a valid identifier
bash: export: `Files/Microsoft': not a valid identifier
bash: export: `Server/100/Tools/Binn:/c/Program': not a valid identifier
bash: export: `Files/Microsoft': not a valid identifier
bash: export: `Server/100/DTS/Binn:/c/Program': not a valid identifier
bash: export: `Files/Microsoft': not a valid identifier
bash: export: `Server/100/Tools/Binn/VSShell/Common7/IDE:/c/Program': not a valid identifier
bash: export: `Files/Microsoft': not a valid identifier
bash: export: `9.0/Common7/IDE/PrivateAssemblies:%USERPROFILE%/.dnx/bin:/c/Program': not a valid identifier
bash: export: `Files/Microsoft': not a valid identifier
bash: export: `DNX/Dnvm:/c/Program': not a valid identifier
bash: export: `Files/nodejs:/c/Users/dell/AppData/Roaming/npm:/usr/bin/vendor_perl:/usr/bin/core_perl:/usr/bin': not a valid identifier


Getting this error when open git bash, in windows 7

After that when run any command like grunt or npm i got error
C#
bash: npm: command not found


my export variables are as following
Quote:
dell@dell-PC MINGW32 /d/ProacDoc
$ export
declare -x !::
declare -x ACLOCAL_PATH="/mingw32/share/aclocal:/usr/share/aclocal"
declare -x ALLUSERSPROFILE="C:\\ProgramData"
declare -x APPDATA="C:\\Users\\dell\\AppData\\Roaming"
declare -x COMMONPROGRAMFILES="C:\\Program Files\\Common Files"
declare -x COMPUTERNAME="DELL-PC"
declare -x COMSPEC="C:\\Windows\\system32\\cmd.exe"
declare -x DISPLAY="needs-to-be-defined"
declare -x EXEPATH="C:\\Program Files\\Git"
declare -x FP_NO_HOST_CHECK="NO"
declare -x HOME="/c/Users/dell"
declare -x HOMEDRIVE="C:"
declare -x HOMEPATH="\\Users\\dell"
declare -x HOSTNAME="dell-PC"
declare -x INFOPATH="/usr/local/info:/usr/share/info:/usr/info:/share/info:"
declare -x LANG="en_US.UTF-8"
declare -x LOCALAPPDATA="C:\\Users\\dell\\AppData\\Local"
declare -x LOGONSERVER="\\\\DELL-PC"
declare -x MANPATH="/mingw32/share/man:/usr/local/man:/usr/share/man:/usr/man:/s hare/man:"
declare -x MSYSTEM="MINGW32"
declare -x NUMBER_OF_PROCESSORS="4"
declare -x OLDPWD
declare -x OS="Windows_NT"
declare -x PATH="/c/Users/dell/bin:/mingw32/bin:/usr/local/bin:/usr/bin:/bin:/mi ngw32/bin:/usr/bin:/c/Users/dell/bin:/c/Windows/system32:/c/Windows:/c/Windows/S ystem32/Wbem:/c/Windows/System32/WindowsPowerShell/v1.0:/c/Program"
declare -x PATHEXT=".COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC"
declare -x PKG_CONFIG_PATH="/mingw32/lib/pkgconfig:/mingw32/share/pkgconfig"
declare -x PLINK_PROTOCOL="ssh"
declare -x PRINTER="Send To OneNote 2007"
declare -x PROCESSOR_ARCHITECTURE="x86"
declare -x PROCESSOR_IDENTIFIER="x86 Family 6 Model 42 Stepping 7, GenuineIntel"
declare -x PROCESSOR_LEVEL="6"
declare -x PROCESSOR_REVISION="2a07"
declare -x PROGRAMFILES="C:\\Program Files"
declare -x PS1="\\[\\033]0;\$TITLEPREFIX:\${PWD//[^[:ascii:]]/?}\\007\\]\\n\\[\\ 033[32m\\]\\u@\\h \\[\\033[35m\\]\$MSYSTEM \\[\\033[33m\\]\\w\\[\\033[36m\\]\`__ git_ps1\`\\[\\033[0m\\]\\n\$ "
declare -x PSModulePath="C:\\Windows\\system32\\WindowsPowerShell\\v1.0\\Modules \\"
declare -x PUBLIC="C:\\Users\\Public"
declare -x PWD="/d/ProacDoc"
declare -x ProgramData="C:\\ProgramData"
declare -x SESSIONNAME="Console"
declare -x SHELL="/usr/bin/bash"
declare -x SHLVL="1"
declare -x SQL
declare -x SSH_ASKPASS="/mingw32/libexec/git-core/git-gui--askpass"
declare -x SYSTEMDRIVE="C:"
declare -x SYSTEMROOT="C:\\Windows"
declare -x Studio
declare -x TEMP="/tmp"
declare -x TERM="xterm"
declare -x TMP="/tmp"


What I have tried:

I have googled about it and tried by solutions like setting environment variables, export PATH and reinstall nodejs and gitbash some other
Posted
Comments
Mohibur Rashid 27-Apr-16 2:04am    
you should give cygwin a try

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900