Click here to Skip to main content
14,668,470 members
Rate this:
Please Sign up or sign in to vote.
See more:
hi.
i am developing s/w in c#, using vs2010,and mssql. i was connecting the finger print device with my s/w. for that i convert the ocx file to dll in my system. then the software working fine in my system. i debug the software in x86. but the software is not working fine in my client system. when that call the fingerprint device dll it show the

"Class not Registered(Exception From HRESULT:0x80040154(REGDB_E_CLASSNOTREG))".

at the end of the error it show the line number of that dll calling function. so i tried to register the dll in my client system but i got the error

" The Module Failed to load. Make sure that the binary" is stored at the specified path or debug to check for problems with the binary or dependent dll files. the specified module could not be found"



now i am clueless... if someone give the solution i really appreciate them.. thank you... advance thanks....

What I have tried:

i tried everything to register the dll. but i can't. open the cmd as administrator, using regsvr32 name.dll, copy the dll and paste it in system32, and register the dependent dll like msvcrt20, msvcrt40, mfc30,mfc40,olepro32,,,,, but nothing helpfull..
Posted
Comments
F-ES Sitecore 5-Jul-16 4:08am
   
What do you mean that you converted the ocx into a dll? If this is a third-party system go back to the ocx and just install it on the client via the standard installation procedure.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month



CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100