Click here to Skip to main content
14,028,553 members
Rate this:
 
Please Sign up or sign in to vote.
See more:
When i start my project it runs fine and UI is loaded and when i click the button after entering values, it shows error.At button click i have called a method.

private void button_Click(object sender, RoutedEventArgs e)
        {
            CompositionHelpers.CalculatorComposition calc = new CompositionHelpers.CalculatorComposition();
            var result = calc.GetResult(Convert.ToInt32(textBox1.Text), Convert.ToInt32(textBox2.Text));
            textBox3.Text = result.ToString();
        }


Method is called from the file:

public class CalculatorComposition
    {
        [Import(typeof(ICalculator))]
        public ICalculator CalciPlugin { get; set; }

        public void AssembleComponents()
        {
            try
            {
                var catalog = new AssemblyCatalog(Assembly.GetExecutingAssembly());
                var container = new CompositionContainer(catalog);
                container.ComposeParts(this);


            }
            catch (Exception ex)
            {
                throw ex;
            }
        }

            public int GetResult(int num1, int num2)
        {
            return CalciPlugin.GetNumber(num1, num2);
        }

       
    }

which enforces contract:
public interface ICalculator
  {
      int GetNumber(int Num1, int Num2);
  }


Please help me out to resolve this issue.
we are using managed extensibility framework?

What I have tried:

I have tried to reslove the issue but it is still present?
Posted
Updated 9-Jan-17 20:03pm

1 solution

Rate this: bad
 
good
Please Sign up or sign in to vote.

Solution 1

This is one of the most common problems we get asked, and it's also the one we are least equipped to answer, but you are most equipped to answer yourself.

Let me just explain what the error means: You have tried to use a variable, property, or a method return value but it contains null - which means that there is no instance of a class in the variable.
It's a bit like a pocket: you have a pocket in your shirt, which you use to hold a pen. If you reach into the pocket and find there isn't a pen there, you can't sign your name on a piece of paper - and you will get very funny looks if you try! The empty pocket is giving you a null value (no pen here!) so you can't do anything that you would normally do once you retrieved your pen. Why is it empty? That's the question - it may be that you forgot to pick up your pen when you left the house this morning, or possibly you left the pen in the pocket of yesterdays shirt when you took it off last night.

We can't tell, because we weren't there, and even more importantly, we can't even see your shirt, much less what is in the pocket!

Back to computers, and you have done the same thing, somehow - and we can't see your code, much less run it and find out what contains null when it shouldn't.
But you can - and Visual Studio will help you here. Run your program in the debugger and when it fails, VS will show you the line it found the problem on. You can then start looking at the various parts of it to see what value is null and start looking back through your code to find out why. So put a breakpoint at the beginning of the method containing the error line, and run your program from the start again. This time, VS will stop before the error, and let you examine what is going on by stepping through the code looking at your values.

But we can't do that - we don't have your code, we don't know how to use it if we did have it, we don't have your data. So try it - and see how much information you can find out!
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month


Advertise | Privacy | Cookies | Terms of Service
Web02 | 2.8.190419.4 | Last Updated 10 Jan 2017
Copyright © CodeProject, 1999-2019
All Rights Reserved.
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100