Click here to Skip to main content
13,090,299 members (89,741 online)
Rate this:
Please Sign up or sign in to vote.
I've just set up a new VPN connection on my Windows 7 Home Premium machine, and I am connected to the VPN, but I can't connect to the server on the VPN using Remote Desktop. The server is accepting RD connections, as my client has just opened one to check before giving me details to connect. If I ping the server I'm trying to connect to I get replies from a different external (196) address, saying "destination net unreachable".

I really doubt it's my router because I connected through the same router earlier this year from my previous, Windows Server 2008 R2 machine with no problems, and nothing has changed on the router. Besides, the ping replies are coming from outside.

One thing that might just be pertinent is that my VPN connection failed the first time I tried using an IP address for the VPN, but succeeded the second time when I used the domain name for the VPN.
Posted 9-Oct-10 1:26am
DaveAuld 9-Oct-10 7:32am
What type of router are you using?
Brady Kelly 9-Oct-10 7:37am
It's a Bipac 7300, but the same router worked with factory defaults on my previous laptop.

1 solution

Rate this: bad
Please Sign up or sign in to vote.

Solution 1

You VPN connection is a Virtual Private Network or secure tunnel into your network.

RDP will exist on a port on your network, (WinRDP is 3389), so you need to ensure that the VPN connection is open before trying to then connect to the RDP port.

You will also need to ensure the necessary ports are open on your machines, and you might have to configure your Router to allow connection on the VPN Port 3389 to map through NAT to internal network IP port 3389.

Depending on your router this may be shown as port redirection, open ports or services.

The end point must also allow the Firewall to allow inbound connections on the port.
Brady Kelly 9-Oct-10 7:38am
The VPN connection is indeed open when I try the RDP connection, and my client connected just before giving me details, so the end point is accepting inbound connections. I have used this VPN and RDP connection many times before I had Windows 7 with no problems. I'm checking my firewall now.
Brady Kelly 9-Oct-10 8:28am
It was indeed the router, which wasn't on factory defaults. Once I reset it, all was working again.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

  Print Answers RSS
Top Experts
Last 24hrsThis month

Advertise | Privacy |
Web01 | 2.8.170813.1 | Last Updated 9 Oct 2010
Copyright © CodeProject, 1999-2017
All Rights Reserved. Terms of Service
Layout: fixed | fluid

CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100