Click here to Skip to main content
14,421,575 members
Rate this:
Please Sign up or sign in to vote.
See more:
os:win7-32 vc10
first I use "perl configure no-shared VC-WIN32",then nmake,nmake test and nmake install.It works well,I got the directory openssl in "c:\\program files" and ssl in "c:\\program files\common files".
I used the openssl to build static curl 7.52.1,my curl build command is nmake /f makefile.vc vc=10 mode=static with_ssl=static,everything works fine untill I used them in my project,It still needs the libssl-1_1.dll and libcrypto-1_1.dll.I've checked for many times with my openssl build configuration and I found,no matter whether I add "no-shared" option to commandline,the configuration's "SHARED_CFLAG" is always empty.Does it have anything to do with my problem?Or it has another reason.

What I have tried:

build it at least 3 or 4 times,tried for vc-win32 ,no-shared vc-win32,vc-win32 no-shared...
Posted
Comments
Graeme_Grant 22-Feb-17 22:24pm
   
Too vague. What is the error message that you are seeing? Please update your question with the information by clicking on Improve question.
TimGallin 22-Feb-17 22:57pm
   
there is no error message,I'm just wonder why i build curl and openssl static but still need openssl related dll in my own project.
Karthik_Mahalingam 23-Feb-17 12:22pm
   
Always use  Reply  button, to post Comments/query to the user, so that the user gets notified and responds to your text.
Jochen Arndt 23-Feb-17 3:06am
   
You might use the Dependency Walker (http://www.dependencywalker.com/) to check which module requires the DLLs.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 503-250 Ferrand Drive Toronto Ontario, M3C 3G8 Canada +1 416-849-8900 x 100