Click here to Skip to main content
15,942,847 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi all

I have an automated build system.
In that i tried to build a VS sln file of a QT project, uisng a cmd.exe. The command which i used for that is as follows,
msbuild qtproject.sln /t:Build /p:Configuration=Release /p:Platform=x64 /v:d
But the build process stoped with an error, Project: error PRJ0019: A tool returned an error code from "Moc" ing tkConnect.h.
can any body tell me why it is happening? :)
Whether we need to setup additional environment varible for this?
Thanks,
Prasanth
Posted

1 solution

XML
hi!
i created batch file setqtvars.bat :

------------------------------------------------------------

@echo on
echo Setting up a Qt64 environment...

set QTDIR=d:\QT\2010_05\qt64
set PATH=%QTDIR%\bin;%PATH%
set QMAKESPEC=win32-msvc2008

call "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\amd64\vcvarsamd64.bat"

c:\Windows\Microsoft.NET\Framework64\v3.5\MSBuild.exe %*

------------------------------------------------------------

and i'am calling not directly MSBuild but this batch with arguments for MSBuild.exe. I'am using this in CruiseControl.Net+SVN+MSBuild+Qt(64):

task block in ccnet.config:

<msbuild>
  <executable>d:\Qt\2010_05\qt64\bin\setqtvars.bat</executable>
  <workingDirectory>D:\svn\server</workingDirectory>
  <projectFile>server.sln</projectFile>
  <buildArgs>/v:diag /p:Configuration="Release" /p:Platform="x64"</buildArgs>
  <targets>Rebuild</targets>
  <timeout>600</timeout>
  <logger>c:\Program Files (x86)\CruiseControl.NET\server\Rodemeyer.MsBuildToCCNet.dll</logger>
</msbuild>


I hope this help... MSBuild with Qt64 and CC.net was really problem... Now it's ok :) my email: vdovdo@azet.sk
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900