Click here to Skip to main content
14,880,764 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
I cannot registry ActiveX dll on Windows 7 -64 bit
This ActiveX dll is successfully registering on Windows 7 - 32 bit
This dll is built in Visual Studio 6, Win 7 - 32 bit
I also tried to registry dll built in Win 7 - 64 bit, but it failed as well.

The message that I receive:" The module "XYZ" failed to load.."
I tried to open this dll in Dependency walker I see the following dlls were not found:

(these dlls I didn't find neither in Win 7 -32 bit or Win 7 -64 bit
Can you please navigate what can be a problem?
Can it be related that dll created in old environment: Visual Studio 6?


What I have tried:

I tried to run regsvr32.exe from command prompt with administrator privileges from C:\Windows\SysWOW64 and from C:\Windows\System32 but no effect
Updated 29-Nov-17 4:48am
CHill60 29-Nov-17 11:01am
If it was build with Visual Studio 6 then it won't register on 64 bit
Nika34 30-Nov-17 1:46am

1 solution

This problem seems related to missing the Visual studio "redistributable package."
Install "redistributable package"

Try this link

I have not tried myself so, let me know if this works.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900