Click here to Skip to main content
14,979,508 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hi,

I've written an application in C# with SQL server compact 3.5 database as back-end engine. I've successfully deployed this application in an x64 Windows 7 virtual machine running on my development machine. However when I take this setup to another computer and install it, it installs good When I run it however, it returns me an error message from Windows.
I've run fuslogvw on the target machine and the Log doesn't seem to tell of any errors. I may be wrong please I need guidance.

What I have tried:

From FUSLOGVW:

*** Assembly Binder Log Entry  (12/5/2017 @ 9:45:19 PM) ***

The operation was successful.
Bind result: hr = 0x0. The operation completed successfully.

Assembly manager loaded from:  C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll
Running under executable  C:\Program Files\FUBUH GROUP\SHOPPER\THESHOP.exe
--- A detailed error log follows. 

=== Pre-bind state information ===
LOG: User = ZEWEN-PC\ZEWEN
LOG: DisplayName = System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
 (Fully-specified)
LOG: Appbase = file:///C:/Program Files/FUBUH GROUP/SHOPPER/
LOG: Initial PrivatePath = NULL
LOG: Dynamic Base = NULL
LOG: Cache Base = NULL
LOG: AppName = THESHOP.exe
Calling assembly : System.Data.SqlServerCe, Version=3.5.1.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91.
===
LOG: This bind starts in default load context.
LOG: Using application configuration file: C:\Program Files\FUBUH GROUP\SHOPPER\THESHOP.exe.Config
LOG: Using host configuration file: 
LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework\v4.0.30319\config\machine.config.
LOG: Version redirect found in framework config: 2.0.0.0 redirected to 4.0.0.0.
LOG: Post-policy reference: System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
LOG: Binding succeeds. Returns assembly from C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System\v4.0_4.0.0.0__b77a5c561934e089\System.dll.
LOG: Assembly is loaded in default load context.



From Windows Error Reporting:

Problem Event Name:	CLR20r3
  Problem Signature 01:	theshop.exe
  Problem Signature 02:	1.0.0.0
  Problem Signature 03:	5a270356
  Problem Signature 04:	System.Data.SqlServerCe
  Problem Signature 05:	3.5.8080.0
  Problem Signature 06:	4b743b2d
  Problem Signature 07:	15c
  Problem Signature 08:	12
  Problem Signature 09:	System.Data.SqlServerCe.SqlCe
  OS Version:	6.1.7601.2.1.0.256.1
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789
Posted
Comments
Dave Kreskowiak 5-Dec-17 18:01pm
   
The Fusion log is only saying that your application was launched successfully using .NET CLR version 4 instead of the .NET 2-3.5 version your code was compiled against.

Windows Error Reporting is saying that you've got a problem with your code calling SqlServer CE. Is SQL Server CE even installed on the machine? Does the machine have all of the pre-req's installed for SQL Server CE to work?

Did you deploy the database file with your app and put it IN AN APPROPRIATE FOLDER (NOT under PROGRAM FILES!)?

Another quick possibility to get more information is to install the debug version of your app and try running that.
Zen'o_179 7-Dec-17 15:49pm
   
Hello Dave,
followed the advice described by Microsoft here https://msdn.microsoft.com/en-us/library/aa983326.aspx and went for the Private File–Based Deployment method.

I already tried this on other apps I wrote as single solution with a single project. This case however is a solution with two projects

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900