Click here to Skip to main content
15,741,892 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hey When I try to build or compile or debug in my visual studio 2008 ide It starts but after 10 seconds it freezes and says its stopped working So whats wrong with the ide its so stupid

I am using windows 10 64bit version
I am using the professional edition

And if i try to compile or build in visual studio 2010 c++ it gives me this error what do I need to do to fix this

the error is

What I have tried:

I have tried a restart of my machine but nothing
Updated 18-Feb-18 7:09am
phil.o 16-Feb-18 16:01pm    
malloc.h is not an error, it is a header file which contains the prototype of the malloc function. You may have to give more useful informations if you want helpful answers. For example, the output console may contain some relevant facts about what is happening during the compilation process.
Member 13244531 17-Feb-18 4:48am    
Here is my console compiling issue on visual studio 2010 but I don't have this issue on visual studio 2008 with the malloc.h so how do I fix this...

1>------ Build started: Project: idlib, Configuration: Release Win32 ------
1> Base64.cpp
1>e:\doom 3 source 2010\src\idlib\precompiled.h(47): fatal error C1083: Cannot open include file: 'malloc.h': No such file or directory
2>------ Build started: Project: Game, Configuration: Release Win32 ------
2> AF.cpp
2>e:\doom 3 source 2010\src\game\../idlib/precompiled.h(47): fatal error C1083: Cannot open include file: 'malloc.h': No such file or directory
========== Build: 0 succeeded, 2 failed, 0 up-to-date, 0 skipped ==========

Apparently malloc.h header has been replaced in VS 2010.
You could try replacing
#include <malloc.h>
#include <stdlib.h>
in your source code, and see if that works.
Share this answer
Be sure to install all service packs of the Visual Studio 2008, because some bug fixes and enhancements are in it.

Why dont you use the latest version of Visual Studio?

Tip: read the complete error message and than thin about it and google for it. When you ask again provide the full error message in the question.
Share this answer

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)

CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900