Click here to Skip to main content
15,032,063 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
// external variables
int fake3D;
F3DFloor *fakeFloor;
fixed_t fakeHeight;
fixed_t fakeAlpha;
int fakeActive = 0;
fixed_t sclipBottom;
fixed_t sclipTop;
HeightLevel *height_top = NULL;
HeightLevel *height_cur = NULL;
int CurrentMirror = 0;
int CurrentSkybox = 0;

CVAR(Int, r_3dfloors, true, 0);

// private variables
int height_max = -1;
TArray<HeightStack> toplist;
ClipStack *clip_top = NULL;
ClipStack *clip_cur = NULL;


namespace Multithreading_doom {

	public ref class Class2
	{




		void mutlthreadRenderer()

		{

			// this is the method for the renderer code to be executed with multithreading with the variable t....

			/*
			**	r_3dfloors.cpp
			**	software 3D floors addon
			**
			**	by kgsws
			*/



	

			 void R_3D_DeleteHeights()
at this bracket is where it says to put the ";" {
				height_cur = height_top;
				while (height_cur) {
					height_top = height_cur;
					height_cur = height_cur->next;
					M_Free(height_top);
				}
				height_max = -1;
				height_top = height_cur = NULL;
			}


it says that I need a ";" at the first bracket. BUT it does not work.

What I have tried:

I have tried everything i cant seem to figure it out
Posted
Updated 8-Apr-18 13:48pm

1 solution

The compiler consider that R_3D_DeleteHeights() is part of mutlthreadRenderer(), thus the mossing ;.
The reason is that you forgot to close the renderer with a }
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900