Click here to Skip to main content
15,067,335 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
i have 2 servers one have TFS 2015 and Other one have 2018. I tried many times to restore 2015 to 2018, But not success. I can't stop 2015 server to take backup Because it is a live database. So i got backup from SQL server and try to restore to SQL 2017.
Database successfully restored but I can't login to the TFS.

Error : 1
TF30046: The instance information does not match. Team Foundation expected a4ad68c8-f8ab-4088-9d75-dc9ac4e8198b which was not found. Please contact your Team Foundation Server administrator.

Error : 2
TF401054: The requested service level property TFS_SERVICE_LEVEL did not match the expected value. Team Foundation Server requires the Dev16.M122.7 service level but the database currently implements Dev14.M113.

How to solve this

What I have tried:

Restore Database from 2015 to 2018
Posted
Updated 30-Apr-18 21:37pm

1 solution

You have to follow the instruction from: How to fix error TFS error TF30046[^]

Do not repost next time. It's rude!
   
Comments
amnk.info 1-May-18 3:44am
   
Sorry for that, I tried many ways. But couldn't solve it. that's why i reposed.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900