Click here to Skip to main content
15,937,127 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
I have uploaded my site to smartasp.net hosting and when I try to access my site by URL I receive this message :
HTTP Error 403.14 - Forbidden
The Web server is configured to not list the contents of this directory.

my web.config is :
<?xml version="1.0" encoding="utf-8"?>
<configuration>
<system.webServer >
<defaultDocument>
  <files>
    <add value ="addbook.aspx"/>
  </files>
</defaultDocument>
<directoryBrowse enabled ="true"/>
</system.webServer>
<configuration>
<system.web>
  <customErrors mode="Off"/>
</system.web>
</configuration>
<connectionStrings>
<add name="ConnectionString" connectionString="Data 
Source=SQL7002.site4now.net;Initial Catalog=DB_A3BC09_MonzerKarary;User 
Id=DB_A3BC09_?????????_admin;Password=@???????????;"
providerName="System.Data.SqlClient" />
</connectionStrings>
<system.web>
    <compilation debug="true" targetFramework="4.0"/>
</system.web>
</configuration>


how do I fix this ?!!

What I have tried:

<configuration>
  <system.webServer >
    <defaultDocument>
      <files>
        <add value ="addbook.aspx"/>
      </files>
    </defaultDocument>
    <directoryBrowse enabled ="true"/>
  </system.webServer>
  <configuration>
Posted
Updated 24-May-18 23:23pm

If the host you are using doesn't allow\support custom default documents just create a default.aspx page on your site that does a redirect to your desired default page.
 
Share this answer
 
Quote:
I have uploaded my site to smartasp.net hosting

You have to talk with their support. If someone know what you can do and how, it is them.
 
Share this answer
 

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900