Click here to Skip to main content
14,827,034 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
While I am trying to build my windows application, I am getting following error.

The command "C:\repos\CommunityLive\CL_GateApp\signing\StrongNameUnsignedAssemblies.bat C:\repos\CommunityLive\CL_GateApp\signing\" exited with code 2.


What I have tried:

Following is my Pre-Build event command line

$(ProjectDir)signing\StrongNameUnsignedAssemblies.bat $(ProjectDir)signing\

Here is the Macros details

[![Macros][1]][1]

		


  [1]: https://i.stack.imgur.com/slCzG.png
Posted
Updated 29-Jun-18 10:27am
Comments
Richard MacCutchan 20-Jun-18 6:12am
   
You need to check the documentation for CommunityLive\CL_GateApp\signing, whatever that is.
Jochen Arndt 20-Jun-18 6:36am
   
The batch file returned with exit code 2.
So it would be good to see the content of that file.

An error code (also exit code) of 2 means "File not found".

So, somewhere in your batch file, a file was specified that doesn't exist and whatever command that tried to execute exited with that exit code.

Since we know nothing about your batch file, it's impossible to tell you anything beyond this.
   
Comments
Salman350 21-Jun-18 6:27am
   
batch file is available at the expected location but still getting this issue.
Dave Kreskowiak 21-Jun-18 8:40am
   
It has nothing to do with the batch file "being available". It has to do with the commands that batch file is running and the parameters being passed to those commands.
It is solved by the creater himself. I really dont know what he did. Thanks for your efforts.
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900