Click here to Skip to main content
14,690,522 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
See more:
Hello,

I have developed an Outlook Add-In using Visual Studio 2008 and VSTO 3.0 targetted for outlook 2007. It loads fine in the development machine.

I have developed an installer for it and installed all the following prerequisites in a different xp sp2 machine for the end user:

MS-Office 2007 and Microsoft .NET Framework 3.5 sp1
Microsoft Visual Studio Tools for the Microsoft Office system (version 3.0 Runtime)
Primary Interop Assemblies for the 2007 Microsoft Office system.
Windows Installer 3.1

Under the 'User code groups', I have given full trust to the entire folder where I have the dll. Everything is fine till here, but I still get the error 'Not loaded. a runtime error occurred during the loading of the com add-in' and the Load Behavior changes to 2 instead of being three.

I have been trying hard to fix this but nothing is favouring my efforts. Any help would be greatly appreciated. Thanks in advance

-- Varma
Posted
Comments
DaveAuld 7-Nov-10 5:53am
   
Have you has a look at the system event viewer to see what errors have been recorded there? Sometimes there is additional information.

1 solution

Hello,

I changed the manifest value to the Manifest value to 'C:\Program Files\ABC\crmEZOutlook4Add-In\crmEZOutlook4.vsto|vstolocal'.
Now, on startup outlook slapped me with the following error:
From: file:///C:/Program Files/ABC/crmEZOutlook4Add-In/crmEZOutlook4.vsto
Application manifest has either a different computed hash than the one specified or no hash specified at all.

As a next step,

1) I edited the 'ThisAddIn.cs' file and built the entire project and ensured that files below show
the latest modified date:
crmEZOutlook4.vsto
crmEZOutlook4.dll
crmEZOutlook4.dll.manifest
crmEZOutlook4.pdb
crmEZOutlook4.dll (Web Configuration File) need not show the latest modified date).
Some other office reference dll's will have 'version 12.0.0.0' and remaining 'version 9.0.0.0'.


2) In the regsitry, under the HKEY_CURRENT_USER hierarchy, The 'Manifest' value of the AddIn key should be pointed to
"C:\Program Files\ABC\crmEZOutlook4Add-In\crmEZOutlook4.vsto|vstolocal".

3) Under the user code groups of 'Microsoft .NET Framework 2.0 Configuration' in 'Administrative Tools', ensure the
following:
a) The name in the General tab.
b) Under the 'Membership condition' tab,
Choose the condition type for this code group: URL
URL : C:\Program Files\CompanyName\productname\*
c) Permission set tab
Permission Set: FullTrust.

4) Depending on your product features, if you need vsto 3.0 sp1
HKEY_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> vsto runtime Setup ->
v9.0.21022 indicates VSTO 3.0 runtime
v9.0.30729 indicates VSTO 3.0 runtime SP1
You may not be able to see 'VSTO 3.0 runtime SP1' in the 'Add/Remove programs' of control panel after u install this;
it may still remain as 'VSTO 3.0 runtime' but registry entry is perfect to know its existence.

After all this, My outlook add-in loaded fine.


Thanks & Regards,
Varma
   

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900