Click here to Skip to main content
15,940,921 members
Please Sign up or sign in to vote.
0.00/5 (No votes)
The Windows service is trying to connect to TCP Port and read data.
The service worked fine on developer machine but when it is deployed to a laptop for demo purpose the service is trying to connect to the TCP but not getting connected.

Please suggest if any permissions are missing.

Also, I try to start the Windows service from WPF application. The service starts when the WPF application is run from VS but when i ran the WPF application exe it is not starting the Windows Service. Access Denied is the error message received.
Please help with the permissions that are to be provided to run the service from WPF application.

What I have tried:

I ran the application with Administrator permissions but it fails.
Posted
Comments
[no name] 29-Oct-18 14:25pm    
Ping the IP address from the laptop ... Can't connect what you can't "see".
sirisha.basavaraju 30-Oct-18 4:03am    
I am able to resolve these issues. The service is being blocked by Firewall so it is not connecting to the client.
Also, I provided the Full control permissions for Users group on the service in regedit and that resolved the issue

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)



CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900