Click here to Skip to main content
14,737,792 members
Please Sign up or sign in to vote.
3.00/5 (1 vote)
I have published a basic .net core app in Azure Appservice. I followed many articles and did it successfully. I even attached remote debugger for the published app in visual studio. But the debugger is not hitting the startup class also, App just simply returns 500 error and says currently unable to handle requests.

Application is working fine locally and I have also hosted it in IIS, In Intranet it's working fine!

Please advise what could be the fault in this case.

What I have tried:

I enabled debugging mode in azure app service and attached debugger in visual studio for the published app. But, not even startup class is hitting when URL is triggered.
Posted
Updated 22-Nov-18 3:53am
v2

1 solution

That process needs to be debugged, you can use the Production Testing to do that, or you can even try to connect the Visual Studio to the live environment and do a live testing of the application. That way you will understand what is being missed on the environment; perhaps a missing configuration setting, or unaccessible resource.

Testing in Production with Microsoft Azure[^]
Troubleshoot a web app in Azure App Service using Visual Studio | Microsoft Docs[^]
   
Comments
Sai_95 23-Nov-18 4:31am
   
Thanks, @Afzaal I tried attaching the remote debugger and followed all the steps, but it didn't help.
Finally, I created a deployment slot for the same app and published the app on it. Now with the deployment slot URL, the application is working fine.

I anticipate that the original publish file doesn't pick my latest changes. I'm not sure what's wrong with it and I'm still trying to accomplish it.

Will the reset publish profile works? But I need to get credentials from my manager, which is not possible at this time.
Afzaal Ahmad Zeeshan 23-Nov-18 6:26am
   
Might be, because deployment slots are the same settings and configuration environments nonetheless. So something might have been missed during deployment.

Reset publish profile does not help with this case. Try redeploying automatically, if you have access. Publish profile is just a connection between your machine and Azure's pod for your app.

This content, along with any associated source code and files, is licensed under The Code Project Open License (CPOL)




CodeProject, 20 Bay Street, 11th Floor Toronto, Ontario, Canada M5J 2N8 +1 (416) 849-8900